Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.5 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Agent Dont communicate with server

Hi, 

My principal error is with Agent 2.4 and server 2.5 doesnt communicate :

COM SERVER => Initializing cURL library for sendRequest

COM SERVER => Using cURL with server authentication

COM SERVER => Disabling cURL proxy support

COM SERVER => Disabling cURL SSL server validation support

COM SERVER => Sending HTTP Post request to URL <http://soportesrv/ocsinventory>

COM SERVER => HTTP Post response received <HTTP Status Code #404>

COM SERVER => Cleaning cURL library

ERROR *** AGENT => Failed to send Prolog <HTTP Status Code #404>

AGENT => Unloading communication provider

AGENT => Unloading plug-in(s)

AGENT => Execution duration: 00:00:01.

 

I read in this forum that i have to enable two sites with a2ensite that came in rar file , but it doesnt work , i enable it , but doesnt work 


I appreciate your help to solve this problem i tried to resolve this too much days,

Thanks in advanced

PD: Where i can email the logs?

asked in OCS Inventory NG agent for Windows by (240 points)

6 Answers

0 votes

Hi,

"soportesrv" name's is correctly resolved by your dns?

Try this url directly from your browser. This is to verify that mod_perl is enabled => http://soportesrv/ocsinventory 

Regards

Frank

answered by (66.4k points)
0 votes

Hi Frank, Thanks for your support, i just test with URL http://soportesrv/ocsinventory  and DNS resolves this URL, but it appear this Error " The requested URL /ocsinventory was not found on this server."  , i try to enable mod_perl, but i couldnt, do you help me to enable ?

Thanks for your help

answered by (240 points)
0 votes
Hi

On which distro have you installed OCS server?

Best regards

Frank
answered by (66.4k points)
0 votes

Hi Frank , 

Its installed on 

  • Ubuntu 18.04.1 LTS , but still cant communicate with server
Best regards
answered by (240 points)
0 votes
Hi

Is iptables or firewalld enabled on the server? Try to stop the firewall and relaunch an inventory.

Best regards

Frank
answered by (66.4k points)
0 votes

its disabled , but still have error with agent, this is command from server:

 ufw status

Status: inactive

--------------------------------------------------------------------------------

This is error with agent :

AGENT => Using Communication Provider <OCS Inventory NG cURL Communication Provider> Version <2.4.0.0>

AGENT => Sending Prolog

DID_CHECK => Read DeviceID <TIOP01-2018-12-03-11-26-01> and MACs <5A:6A:20:52:41:532C:27:D7:39:86:C816:74:11:C4:B0:9A00:09:0F:FE:00:0100:09:0F:AA:00:0100:50:56:C0:00:0100:50:56:C0:00:08> in file <ocsinventory.dat>

COM SERVER => Initializing cURL library for sendRequest

COM SERVER => Using cURL without server authentication

COM SERVER => Disabling cURL proxy support

COM SERVER => Disabling cURL SSL server validation support

COM SERVER => Sending HTTP Post request to URL <http://soportesrv/ocsinventory>

COM SERVER => HTTP Post response received <HTTP Status Code #404>

COM SERVER => Cleaning cURL library

ERROR *** AGENT => Failed to send Prolog <HTTP Status Code #404>

AGENT => Unloading communication provider

AGENT => Unloading plug-in(s)

AGENT => Execution duration: 00:00:01.

Best regards

answered ago by (240 points)
 
Powered by Question2Answer
...