Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.5 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Help troubleshoot: Couldn't connect to server [closed]

Hi all,

We have a newly installed ocs inventory ng server version 2.5 on Centos 7.

I’m trying to get my first agent to communicate with the server. It’s the Windows agent 2.4 on a server 2008 box. However, I only get “Failed to send HTTP Post request <Couldn't connect to server>”

I have stopped the firewalls on both the server and client. If I point my browser to: http://ipaddress_of_ocs/ocsinventory, I get page not found.

Here is some HTTP info:

Server: Apache/2.4.6 (CentOS) OpenSSL/1.0.2k-fips PHP/5.4.16 mod_perl/2.0.10 Perl/v5.16.3

Here is my ini:

[OCS Inventory Agent]
ComProvider=ComHTTP.dll
Debug=2
Local=
NoSoftware=0
HKCU=0
NoTAG=1
IpDisc=
[HTTP]
Server=http://ipaddress_of_ocs/ocsinventory
SSL=0
CaBundle=cacert.pem
AuthRequired=0
User=
Pwd=
ProxyType=0
Proxy=
ProxyPort=0
ProxyAuthRequired=0
ProxyUser=
ProxyPwd=
[OCS Inventory Service]
TTO_WAIT=2220
INVENTORY_ON_STARTUP=0

Here is my OCSInventory.log:

Starting OCS Inventory NG Agent on Monday, December 03, 2018 10:36:33.

AGENT => Running OCS Inventory NG Agent Version 2.4.0.0
AGENT => Using OCS Inventory NG FrameWork Version 2.4.0.0
AGENT => Loading plug-in(s)
DLL PLUGIN => Searching for Plug-in DLL(s) in folder <C:\Program Files (x86)\OCS Inventory Agent\plugins>
DLL PLUGIN => 0 DLL Plug-in(s) successfully loaded on 0 DLL(s) found
AGENT => Using network connection with Communication Server
COM PROVIDER => Loading Communication Provider <C:\Program Files (x86)\OCS Inventory Agent\ComHTTP.dll>
AGENT => Using Communication Provider <OCS Inventory NG cURL Communication Provider> Version <2.4.0.0>
AGENT => Sending Prolog
DID_CHECK => Read DeviceID <RDP2-2018-12-03-07-29-28> and MACs <C2:A8:20:52:41:5300:50:56:9C:24:1400:50:56:9C:3F:9900:50:56:9C:19:FB00:50:56:80:F4:02> in file <ocsinventory.dat>
COM SERVER => Initializing cURL library for sendRequest
COM SERVER => Using cURL without server authentication
COM SERVER => Disabling cURL proxy support
COM SERVER => Disabling cURL SSL server validation support
COM SERVER => Sending HTTP Post request to URL <http://ipaddress_of_ocs/ocsinventory>
WARNING *** COM SERVER => Failed to send HTTP Post request <Couldn't connect to server>
COM SERVER => Cleaning cURL library
================= TRACE START ===============

================= TRACE STOP ===============
ERROR *** AGENT => Failed to send Prolog <Couldn't connect to server>
AGENT => Unloading communication provider
AGENT => Unloading plug-in(s)
AGENT => Execution duration: 00:00:22.

Any help is much appreciated.

Thanks, Andrew

closed with the note: I found the issue: The wrong server IP was entered.
asked ago in OCS Inventory NG agent for Unix by (240 points)
closed ago by

1 Answer

0 votes
I found the issue: The wrong server IP was entered.

Now onto the new issues...

Thanks, Andrew
answered ago by (240 points)
 
Powered by Question2Answer
...