Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.6 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

SSO sur OCS implanté sur serveur virtuel Linux lié à un ActiveDirectory Windows

Bonjour,

J'ai un serveur Linux virtuel qui héberge OCS Inventory. Mon serveur OCS est lié à une Base Active Directory Windows. Donc pour me connecter avec un utilisateur de mon domaine Windows Active Directory, je change les fichier de conf de OCS :

J'ai commenter la méthode 'HTML' et décommenter la méthode 'SSO':
 //If you want a html form for the connexion
 //put $affich_method='HTML'
 //$affich_method='HTML';
 //If you use an SSO connexion
 //use this configuration
 $affich_method='SSO';
 $list_methode=array(0=>"always_ok.php");

Je laisse "local" list_methode :

 $list_methode=array(0=>"local.php");
 //$list_methode=array(0=>"ldap.php");

J'ai mis remote-user en paramètre pour server:


 }elseif($affich_method == 'SSO' and isset($_SERVER['REMOTE_USER'])){
        $login=$_SERVER['REMOTE_USER'];
        $mdp='NO_PASSWD';

Mais lorsque j'essaie de me connecter, après avoir renseigné 3 fois mon ID et mot de passe, une page blanche s'affiche...

Que modifier pour faire marcher ??

in OCS Inventory NG server for Unix by (2k points)

1 Answer

0 votes

Bonjour, en fait il fallait aussi commenter:

  //$list_methode=array(0=>"local.php");

by (2k points)
 
Powered by Question2Answer
...