Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.3 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Les agents ne remonte pas les information du plug in Uptime

Bonjour,

J'ai bien réalisé ce qui est présenter ici ( https://ask.ocsinventory-ng.org/6686/how-to-install-uptime-plugin-coment-installer-le-plug-uptime?show=6688#a6688 ), le plugin est bien ajouté sur le serveur dans "Miscellaneous" et j'ai mis le script dans C:\Program Files (x86)\OCS Inventory Agent\Plugins

Quelqu'un aurait une idée de pourquoi aucune remonté ne se fait? Serait-ce possible que l'antivirus bloque ce script?

Cordialement

asked Apr 21 in OCS Inventory NG server for Unix by Eskignax (860 points)
edited 2 days ago by Eskignax

7 Answers

0 votes
Bonjour,

j'ai installé "uptime" (ainsi que d'autres plugins) sur mon serveur OCS (Debian 8.7 Jessie avec OCS 2.3.1) et je ne rencontre aucun problème de remontée d'infos en configuration multi-sites, avec des antivirus de versions / marques différentes.

Avez-vous installé d'autres plugins OCS de la même façon et fonctionnent-ils ? Avez-vous essayé de générer un XML en local sur la station et de vérifier si les infos concernant "Uptime" sont bien intégrées dedans ?

Cordialement, Stéphane

PS : Merci de requalifier la question qui n'est pas suffisamment explicite (plugin, uptime, windows...)
answered Apr 22 by steph78630 (1,260 points)
edited 2 days ago by steph78630
0 votes
Bonjour,

Tout d'abord escusez moi, j'ai ouvert ce thread en pensant que ca le mettrais a la suite du mon précedent.

Je n'est installé que uptime pour le moment, et lorsque je génére l'inventaire en local, je n'ai rien en rapport avec l'uptime. Peut être dois-je faire une opération supplémentaire sur les clients?

Cordialement
answered 5 days ago by Eskignax (860 points)
0 votes
Bonjour,

dans votre dernière réponse, il semble que votre script "uptime.vbs" ne soit tout simplement pas exécuté par l'agent OCS.

Pour les clients sous Windows 64 bits, il faut placer le script "uptime.vbs" dans le répertoire :

C:\Program Files (x86)\OCS Inventory Agent\Plugins\

> Ce même répertoire a été crée au moment de l'installation de l'agent sur le client, vous ne devez pas le créer vous-même (plusieurs erreurs dans l'arborescence que vous indiquez dans votre post initial).

Une fois le script VBS dans ce répertoire (et d'autres si vous en avez le besoin), il est automatiquement exécuté et exploité par l'agent lors de la génération d'un nouvel inventaire.

Vérifier votre arborescence OCS sur le PC client...

Stéphane
answered 2 days ago by steph78630 (1,260 points)
edited 2 days ago by steph78630
0 votes
Bonjour, merci de votre réponse.

C'est de ma faute, quand j'ai fais le poste je n'avais pas le chemin devant les yeux du coup j'ai mis un chemin aproximatif.

Donc oui, uptime.vbs est bien dans C:\Program Files (x86)\OCS Inventory Agent\Plugins
answered 2 days ago by Eskignax (860 points)
0 votes
Ok, alors un problème se situe certainement au niveau du client, car si le contenu du vbs est conforme et bien placé, aucune raison qu'il n'apparaisse pas dans le fichier XML... Par exemple, on devrait y trouver :

        <UPTIME>
            <TIME>0 jours, 3 heures, 56 minutes</TIME>
        </UPTIME>

A part les infos d'uptime, l'inventaire du client remonte t-il bien dans le serveur ?

Avez-vous essayé d'exécuter manuellement ce script VBS ? Cela doit afficher consécutivement 3 fenêtres "Windows Script Host" représentant chaque ligne insérée dans le fichier XML. Si ce n'est pas le cas, peut-être avez-vous un soucis de corruption de Windows / exécution de WMI (un outil comme ccleaner pourrait éventuellement régler le pb).

Sinon, vous pouvez aussi essayer de réinstaller l'agent sur le client Windows ; Pour cela, je procèderais d'abord à une désinstallation complète plutôt qu'une réinstallation "par dessus"...

1 - Sauvegardes :

     Certificat cacert.pem dans C:\ProgramData\OCS Inventory NG\Agent\

     Contenu du dossier C:\Program Files (x86)\OCS Inventory Agent\Plugins

2 - Désinstallation de l'agent OCS par : C:\Program Files (x86)\OCS Inventory Agent\uninst.exe

3 - Redémarrage de Windows puis suppression manuelle des répertoires :

     C:\ProgramData\OCS Inventory NG\Agent\

     C:\Program Files (x86)\OCS Inventory Agent\

4 - Réinstallation de l'agent OCS version 2.3.0.0

5 - Copie du fichier cacert.pem et plugins VBS dans leurs répertoires respectifs

6 - Génération d'un inventaire en local (XML sur C:\ dans l'exemple) :

"C:\Program Files (x86)\OCS Inventory Agent\OCSInventory.exe" /local /xml="C:\"

Bon courage, Stéphane
answered 2 days ago by steph78630 (1,260 points)
edited 2 days ago by steph78630
0 votes
Bonjour,

Je viens de notifier quelque chose, en XML, j'ai bien une partie UPTIME qui apparait, mais quand je fais "afficher les informations d'inventaire" je ne voit rien qui concerne l'uptime.

De plus, sur mon parc, mes clients sont en 2.1.1.3, cela peut il avoir une incidence?

Cordialement
answered 2 days ago by Eskignax (860 points)
0 votes
Bonjour,

Est-ce que la partie "server" du plugin a été installée (fichier Map.pm du plugin)?

Cordialement

Frank
answered 1 day ago by frankb (43,430 points)
 
Powered by Question2Answer
...