Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.4 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

[SOLVED] Agent 2.3.0 running but sever not inventoried.

Hello, everybody,
I have my OCS 2.3.1 server running and working well.
My Windows clients are using agent 2.3.0. and working well.
But I have a PC model that is not inventoried on the server, even though the agent is installed and running, and has a network connection.

The PC is ASUS H110M-R, Intel Core i7-7700, Windows 7 x64 SP1.

This is the OCSInventory.log

OCSInventory.log

==============================================================================

Starting OCS Inventory NG Agent on Tuesday, October 31, 2017 11:19:26.

AGENT => Running OCS Inventory NG Agent Version 2.3.0.0

AGENT => Using OCS Inventory NG FrameWork Version 2.3.0.0

AGENT => Loading plug-in(s)

DLL PLUGIN => Searching for Plug-in DLL(s) in folder <C:\Program Files (x86)\OCS Inventory Agent\plugins>

DLL PLUGIN => 0 DLL Plug-in(s) successfully loaded on 0 DLL(s) found

AGENT => Using network connection with Communication Server

COM PROVIDER => Loading Communication Provider <C:\Program Files (x86)\OCS Inventory Agent\ComHTTP.dll>

AGENT => Using Communication Provider <OCS Inventory NG cURL Communication Provider> Version <2.3.0.0>

AGENT => Sending getLabel request

COM SERVER => Initializing cURL library for getFile

COM SERVER => Using cURL without server authentication

COM SERVER => Disabling cURL proxy support

COM SERVER => Enabling cURL SSL server validation support using CA Bundle <C:\ProgramData\OCS Inventory NG\Agent\cacert.pem>

COM SERVER => Sending fileGet request to URL <http://artaocs01/ocsinventory/deploy/label>

COM SERVER => fileGet response received <HTTP Status Code #400>

COM SERVER => Cleaning cURL library

AGENT => Failed to retrieve Label <HTTP Status Code #400>

AGENT => Sending Prolog

DID_CHECK => Read DeviceID <ARCURAP02-2017-10-31-10-33-05> and MACs <38:D5:47:1C:AF:DE> in file <ocsinventory.dat>

COM SERVER => Initializing cURL library for sendRequest

COM SERVER => Using cURL without server authentication

COM SERVER => Disabling cURL proxy support

COM SERVER => Enabling cURL SSL server validation support using CA Bundle <C:\ProgramData\OCS Inventory NG\Agent\cacert.pem>

COM SERVER => Sending HTTP Post request to URL <http://artaocs01/ocsinventory>

COM SERVER => HTTP Post response received <HTTP Status Code #200>

COM SERVER => Cleaning cURL library

================= TRACE START ===============

<?xml version='1.0' encoding='UTF-8'?>

<REPLY>

  <OPTION>

    <NAME>DOWNLOAD</NAME>

    <PARAM FRAG_LATENCY="10" PERIOD_LATENCY="1" ON="0" TYPE="CONF" CYCLE_LATENCY="60" TIMEOUT="30" PERIOD_LENGTH="10" EXECUTION_TIMEOUT="120" />

  </OPTION>

  <RESPONSE>SEND</RESPONSE>

  <INVENTORY_ON_STARTUP>1</INVENTORY_ON_STARTUP>

  <PROLOG_FREQ>24</PROLOG_FREQ>

</REPLY>

================= TRACE STOP ===============

AGENT => Prolog successfully sent

SUPPORT => No support detected, Registration key : N/A

AGENT => Prolog Frequency set to 24 hour(s)

AGENT => Inventory on startup option set to 1

AGENT => Inventory required

AGENT => Launching hardware and software checks

INVENTORY => Loading Download history

INVENTORY => Logged on user ID is <SYSTEM>

INVENTORY => Operating System is <Microsoft Windows 7 Professional 6.1.7601 Service Pack 1>, description <>

INVENTORY => Operating System uses 64 bits memory address width

INVENTORY => Computer domain or workgroup is <albanet.medios>

WARNING *** INVENTORY => Failed to retrieve user domain

INVENTORY => System Manufacturer <System manufacturer>, System Model <System Product Name>, System S/N <System Serial Number>, Bios Manufacturer <American Megatrends Inc.>, Bios Date <27/12/2016>, Bios Version <3016>, Motherboard Manufacturer <ASUSTeK COMPUTER INC.>, Motherboard Model <>, Motherboard S/N <160881959406255>

INVENTORY => 1 processor(s) Intel(R) Core(TM) i7-7700 CPU @ 3.60GHz [4 core(s) x86_64] at 3601 MHz

INVENTORY => OS Memory 16255 MB, OS Swap size 32509 MB

INVENTORY => 2 memory slot(s) found

INVENTORY => 2 input device(s) found

INVENTORY => 22 system port(s) found
asked Oct 31, 2017 in OCS Inventory NG agent for Windows by _neok (300 points)
edited Nov 2, 2017 by _neok

1 Answer

0 votes
Some BIOS DMI options were interfering with the Agent's performance. When enabling them now the agent correctly informs the server.
Then I'm going to investigate the exact configuration.

Regards
answered Oct 31, 2017 by _neok (300 points)
 
Powered by Question2Answer
...