Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.4.1 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

pas deremonté des agents [closed]

Bonjour,

Je viens de monter un serveur OCS et je n'ai pas de remonté de mon agent windows.

Lorsque je configure l'agent avec l'adresse par defaut j'obtiens une erreur 404 par contre losque je configure l'agent avec l'adresse su serveur ocsreports j'ai un code 200 mais pas de remontés

Je vous joint les logs de l'agent dans les deux configurations.

Je precise que je suis une quiche en Linux et que j'ai tout configuré avec differents Tuto.

Configuration serveur

Système

      Linux x86_64
    4.9.0-4-amd64
    3820 Mo
    2842 Mo
    Intel(R) Pentium(R) CPU G2030 @ 3.00GHz
    Debian GNU/Linux 9 (stretch)

Logiciel

    7.0.27
    Apache/2.4.25 (Debian)
    Debian 9.1 version 10.1.26-MariaDB-0+deb9u1
    2.4

********Client configuré Avec l'adresse ocsreports ********

Starting OCS Inventory NG Agent on Monday, February 26, 2018 11:41:23.
AGENT => Running OCS Inventory NG Agent Version 2.3.1.1
AGENT => Using OCS Inventory NG FrameWork Version 2.3.1.1
AGENT => Loading plug-in(s)
    DLL PLUGIN => Searching for Plug-in DLL(s) in folder <C:\Program Files (x86)\OCS Inventory Agent\plugins>
    DLL PLUGIN => 0 DLL Plug-in(s) successfully loaded on 0 DLL(s) found
AGENT => Using network connection with Communication Server
    COM PROVIDER => Loading Communication Provider <C:\Program Files (x86)\OCS Inventory Agent\ComHTTP.dll>
AGENT => Using Communication Provider <OCS Inventory NG cURL Communication Provider> Version <2.3.1.1>
AGENT => Sending Prolog
    DID_CHECK => Read DeviceID <PO02INFO1000-2018-02-22-11-51-52> and MACs <80:CE:62:2F:54:F260:F6:77:7E:99:DC60:F6:77:7E:99:D860:F6:77:7E:99:D860:F6:77:7E:99:D860:F6:77:7E:99:D860:F6:77:7E:99:D860:F6:77:7E:99:D860:F6:77:7E:99:D8> in file <ocsinventory.dat>
    COM SERVER => Initializing cURL library for sendRequest
    COM SERVER => Using cURL without server authentication
    COM SERVER => Disabling cURL proxy support
    COM SERVER => Disabling cURL SSL server validation support
    COM SERVER => Sending HTTP Post request to URL <http://192.168.0.11/ocsreports>
    COM SERVER => HTTP Post response received <HTTP Status Code #200>
    COM SERVER => Cleaning cURL library
AGENT => Prolog successfully sent
    AGENT => Prolog Frequency set to 10 hour(s)
    AGENT => Inventory on startup option set to  
AGENT => Unloading communication provider
AGENT => Unloading plug-in(s)
AGENT => Execution duration: 00:00:00.

********Client configuré Avec l'adresse ocsinventory ********

Starting OCS Inventory NG Agent on Monday, February 26, 2018 11:50:03.
AGENT => Running OCS Inventory NG Agent Version 2.3.1.1
AGENT => Using OCS Inventory NG FrameWork Version 2.3.1.1
AGENT => Loading plug-in(s)
    DLL PLUGIN => Searching for Plug-in DLL(s) in folder <C:\Program Files (x86)\OCS Inventory Agent\plugins>
    DLL PLUGIN => 0 DLL Plug-in(s) successfully loaded on 0 DLL(s) found
AGENT => Using network connection with Communication Server
    COM PROVIDER => Loading Communication Provider <C:\Program Files (x86)\OCS Inventory Agent\ComHTTP.dll>
AGENT => Using Communication Provider <OCS Inventory NG cURL Communication Provider> Version <2.3.1.1>
AGENT => Sending Prolog
    DID_CHECK => Read DeviceID <PO02INFO1000-2018-02-22-11-51-52> and MACs <80:CE:62:2F:54:F260:F6:77:7E:99:DC60:F6:77:7E:99:D860:F6:77:7E:99:D860:F6:77:7E:99:D860:F6:77:7E:99:D860:F6:77:7E:99:D860:F6:77:7E:99:D860:F6:77:7E:99:D8> in file <ocsinventory.dat>
    COM SERVER => Initializing cURL library for sendRequest
    COM SERVER => Using cURL without server authentication
    COM SERVER => Disabling cURL proxy support
    COM SERVER => Disabling cURL SSL server validation support
    COM SERVER => Sending HTTP Post request to URL <http://192.168.0.11/ocsinventory>
    COM SERVER => HTTP Post response received <HTTP Status Code #404>
    COM SERVER => Cleaning cURL library
ERROR *** AGENT => Failed to send Prolog <HTTP Status Code #404>
AGENT => Unloading communication provider
AGENT => Unloading plug-in(s)
AGENT => Execution duration: 00:00:01.
closed with the note: Problème résolu
asked in OCS Inventory NG agent for Unix by (200 points)
closed by

4 Answers

0 votes
Bonjour,

le module mod_perl pour apache a été installé et configuré ? Des erreurs dans le fichier /var/log/apache2/error.log ?

Cordialement

Frank
answered by (59.3k points)
0 votes
Merci de votre reponse rapide

Ci joint la derniere ligne des logs acces.log et error.log

ERROR.LOG

[Mon Feb 26 14:17:48.504883 2018] [mpm_prefork:notice] [pid 585] AH00169: caught SIGTERM, shutting down
[Mon Feb 26 14:18:10.968603 2018] [mpm_prefork:notice] [pid 542] AH00163: Apache/2.4.25 (Debian) mod_perl/2.0.10 Perl/v5.24.1 configured -- resuming normal operations
[Mon Feb 26 14:18:10.969196 2018] [core:notice] [pid 542] AH00094: Command line: '/usr/sbin/apache2'

ACCESS.LOG

192.168.0.30 - - [26/Feb/2018:14:22:42 +0100] "POST /ocsreports HTTP/1.1" 301 529 "-" "OCS-NG_WINDOWS_AGENT_v2.3.1.1"
192.168.0.30 - - [26/Feb/2018:14:22:42 +0100] "GET /ocsreports/ HTTP/1.1" 200 6688 "-" "OCS-NG_WINDOWS_AGENT_v2.3.1.1"

Pour perl je pense que oui  j'ai installé ocs selon le tuto   https://florianlaloge.fr/2017/06/05/tutoriel-ocsinventory-sous-debian-8/

Cordialement
answered by (200 points)
0 votes
L'url de ton serveur c'est http://192.168.0.11/ocsinventory

ocsreports c'est l'interface d'admin. Voilà ce qui arrive quand on ne lit pas la doc mais un tuto trouvé sur le net :)
answered by (18.1k points)
0 votes
PB resolu, j'ai reinstallé completement j'avais un PB sur ma base SQL.
answered by (200 points)
 
Powered by Question2Answer
...