Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.6 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Je n'arrive pas a lier mon agent ocs à mon serveur

Bonjour,

Je viens de procéder a l'installation de mon serveur OCS inventory qui est donc en 2.5, j'ai réaliser sont installation tout a l'air d'être ok de ce coté j'ai mon serveur sur un vhost qui est sur le port 82, j'accède bien a l'interface web d'OCS mais je n'arrive pas a faire remonter l'inventaire d'un pc sur le visuel de l'interface web.

Je ne sais pas de quelle informations avais vous besoin pour savoir d'ou peux provenir le problème.

Il m'a bien créer toutes les tables dans la base de données etc...

J'ai juste un soucis je pense c'est au niveau du nom de mon serveur OCS puisque j'utilise le port 82 j'ai donc mit dans l'url au niveau de l'agent http://monip:82/ocsinventory

J'ai aussi essayer sans le port mais rien n'y fait je n'ai aucun retour d'inventaire.
in OCS Inventory NG server for Unix by (440 points)

14 Answers

0 votes
Bonjour,

Quelle version de l'agent et sur quel OS? Qu'affiche la page http://@ip:82/ocsinventory depuis un navigateur?

Cordialement

Frank
by (70.2k points)
0 votes

Bonjour,

J'ai eu le même problème sur une toute nouvelle installation Ubuntu Server 18.04 + OCS 2.5.

Après de nombreuses recherches infructueuses (dépendances, pare-feu, etc), il s'est avéré que le module Perl d'Apache n'était pas activé.

Avec la commande (lancée en root)

a2enmod perl

Et après voir relancé Apache, tout s'est mis à fonctionner.

by (160 points)
edited by
0 votes

Bonjour Frank,

Au niveau de ma page http://@ip:82/ocsinventory je n'ai rien mais au niveau de http://@ip:82/ocsreports/ j'ai bien accès a mon interface d'administration etc.

En vous remerciant

by (440 points)
0 votes
Bonjour xdelatour

Je viens d'essayer de lancé le module perl et il m'a directement informer que le module était déjà opérationnel.

En te remerciant.
by (440 points)
0 votes
Je suis sur un debian 9.x 64bits

Sur la version 2.5 d'OCS
by (440 points)
0 votes
Bonjour,

Quelle URL as-tu mis dans le fichier de configuration de l'agent c'est peut-être là ton erreur. Il faut mettre server=http://@ip:82/ocsinventory et non server=http://@ip:82/ocsreports

Cordialement

Frank
by (70.2k points)
0 votes
Au niveau de l'url j'ai essayer avec le nom de domaine ainsi que l'ip, mais aucun moyen de savoir si les informations sont envoyée ou non. Apparament elle ne remonte pas dans l'interface de OCS report.

J'ai bien mit ocsinventory à la fin de mon ip.
by (440 points)
0 votes
Etant donné que la page http://@ip:82/ocsinentory n'affiche rien cela montre que le module mod_perl n'est pas activé. Le résultat doit être : error 400.

Donc le module mod_perl est bien installé? Est-il bien activé ?

Peux-tu poster le contenu du fichier error.log d'apache?
by (70.2k points)
0 votes

Voila les dernières ligne de mon error.log de apache.

j'aurais envie de dire qu'il fonctionne correctement, je venais juste de le reboot deux fois afin de voir ce qu'il ce passer.

Lorsque je vais sur la page /ocsinventory j'ai une erreur 404 Not found

by (440 points)
0 votes
Est-ce que tu utilises un port particulier autre que celui par défaut (80)?
by (70.2k points)
 
Powered by Question2Answer
...