Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.5 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Problème de télédeploiement

Bonjour à tous

Je viens d'installer OCS et l'inventaire de mes postes fonctionne.
Je voudrais deployer des applications ou des mises à jours de logiciels.
Je n'arrive pas à faire fonctionner le deploiement.
Pour tester :
1 - j'ai crée un package sans fichier à uploader (au debut j'ai testé une package de mise à jour de notepad++ mais j'ai simplifié, en voulant dans un premier temps exécuter une commande simple (lancer notepad.exe)
2 - Je l'ai activé
3 - Dans l'inventaire des machine je clic sur la machine sur laquelle je veux qu'il s'exécute
 Puis:  Télédeploiement -> ajouter un paquet -> utiliser les options avancées > je sélectionne mon paquet, je défini une date et dans action j'ai 4 lignes : deux vides, arrêt et redemarrage. et je coche forcer le deployement.

Sur la machine sur laquelle j'ai déployé je vois les paquets activés en statut : ATTENTE NOTIFICATION

J'ai testé les 4 possibilités (proposée dans action). rien ne se passe.
J'ai activé / désactivé SSL dans le client.
Je ne sais pas ou chercher des log pour voir ou cela coince.

Merci

la configuration :

    Nom du système :Linux x86_64
    Version :       4.9.0-8-amd64
    RAM totale :    3937 Mo
    RAM disponible :3452 Mo
    CPU :           Intel(R) Xeon(R) CPU E5506 @ 2
    Distribution :  Debian GNU/Linux 9 (stretch)
    Version de PHP :      7.0.33
    Serveur Web :         Apache/2.4.25 (Debian)
    Serveur SQL :         Debian 9.6 version 10.1.37-MariaDB-0+deb9u1
    Version OCSReports:   2.5
 

asked in OCS Inventory NG agent for Windows by (280 points)

6 Answers

0 votes
Bonjour,

As-tu créé le certificat et l'as-tu copié sur les clients?

Cordialement

Frank
answered by (69.9k points)
0 votes
Bonjour

Je n'ai pas créer de certificat.
J'ai utilisé celui fourni avec le client.

Faut il en créer un spécifiquement pour le deploiement ?
Je ne suis pas familiarisé avec les certificats. Si tu connais une procédure qui explique le méthode je suis preneur sinon je vais chercher

Merci
answered by (280 points)
0 votes

J'ai suivi le procédure (qui est un peu touffue si je peux me permettre )

J'ai éxecuté le script (sh apache_generate_cert.sh)
j'ai copier les fichier dans les répertoires
    cp server.crt /etc/ssl/certs/

    cp server.key /etc/ssl/private/

J'ai copié les fichiers server.crt et server.key dans le répertoire de config du client.

J'ai tout redemarré

Rien de mieux.

Je ne comprends pas ou est le problème et je ne sais pas si il y des fichiers de logs du coté du serveur pour identifier si il y a des problèmes.

Aucun message dans les log du client.


En creusant un peu j'ai trouvé le fichier /var/log/apache2/error.log :
Scalar value @part_query[...] better written as $part_query[...] at /usr/local/share/perl/5.24.1/Apache/Ocsinventory/Interface/AssetCategory.pm line 53.
Scalar value @args[...] better written as $args[...] at /usr/local/share/perl/5.24.1/Apache/Ocsinventory/Interface/AssetCategory.pm line 53.
ocsinventory-server: Can't load SOAP::Transport::HTTP* - Web service will be unavailable
Scalar value @part_query[...] better written as $part_query[...] at /usr/local/share/perl/5.24.1/Apache/Ocsinventory/Interface/AssetCategory.pm line 53.
Scalar value @args[...] better written as $args[...] at /usr/local/share/perl/5.24.1/Apache/Ocsinventory/Interface/AssetCategory.pm line 53.
ocsinventory-server: Can't load SOAP::Transport::HTTP* - Web service will be unavailable
[Tue Mar 19 22:38:16.968190 2019] [mpm_prefork:notice] [pid 713] AH00163: Apache/2.4.25 (Debian) OpenSSL/1.0.2r mod_perl/2.0.10 Perl/v5.24.1 configured -- resuming normal operations
[Tue Mar 19 22:38:16.968246 2019] [core:notice] [pid 713] AH00094: Command line: '/usr/sbin/apache2'
[Tue Mar 19 22:40:27.380352 2019] [:error] [pid 734] [client 192.168.50.242:65361] PHP Warning:  vsprintf(): Too few arguments in /usr/share/ocsinventory-reports/ocsreports/require/function_commun.php on line 74, referer: http://192.168.50.245:4580/ocsreports/index.php
[Tue Mar 19 22:40:27.380423 2019] [:error] [pid 734] [client 192.168.50.242:65361] PHP Warning:  mysqli_query(): Empty query in /usr/share/ocsinventory-reports/ocsreports/require/function_commun.php on line 103, referer: http://192.168.50.245:4580/ocsreports/index.php
[Tue Mar 19 22:40:41.419260 2019] [:error] [pid 735] [client 192.168.50.242:65362] PHP Warning:  vsprintf(): Too few arguments in /usr/share/ocsinventory-reports/ocsreports/require/function_commun.php on line 74, referer: http://192.168.50.245:4580/ocsreports/index.php
[Tue Mar 19 22:40:41.419333 2019] [:error] [pid 735] [client 192.168.50.242:65362] PHP Warning:  mysqli_query(): Empty query in /usr/share/ocsinventory-reports/ocsreports/require/function_commun.php on line 103, referer: http://192.168.50.245:4580/ocsreports/index.php


J'ai donc l'impression qu'il y a un bug.

answered by (280 points)
edited by
0 votes

J'ai appliqué le HotFix #532.

Je n'ai plus d'erreur dans le log de apache. mais le télédployement ne marche pas.

Je cherche toujours ou trouver des log pour me guider dans la résolution de mon problème.

(Quelqu'un sait il quand le 2.6 va être officiellement disponible ?)

Merci

answered by (280 points)
0 votes

J'ai progressé : (Procédure intéressante: ICI Mais qui a quelques bug
- Installation de 2.6RC
- Création des certificats en suivant la procédure ICI Attention à la saisie des informations dans common name il faut saisir l'adresse IP du serveur ou son nom FQDN (l'IP pour moi)
- Modification du fichier /etc/apache2/site-enabled/default-ssl.conf : retirer l'option "Require host localhost"
- Résultat le deployement passe en notified dans OCS mais j'ai toujours une erreur ( voir fin du post)
 Le répertoire est bien accessible en HTTPS avec un navigateur web.

Je ne sais pas ou chercher. je ne sais pas si c'est de download du fichier qui ne marche pas ou si c'est le fichier qui n'est pas Ok.

Je viens de faire l'essai en copiant le répertoire manuellement du seveur vers le client => idem. Le répertoire est quand même supprimé par l'agent.

Une idée comme ça : pour les experts du produit créer une machine virtuelle prête à faire feu ce serait top.


OCSInventory.log avec option debug =1

    COM SERVER => Initializing cURL library for sendRequest
    COM SERVER => Using cURL without server authentication
    COM SERVER => Disabling cURL proxy support
    COM SERVER => Enabling cURL SSL server validation support using CA Bundle <ocsng.pem>
    COM SERVER => Sending HTTP Post request to URL <https://XXX.XXX.XXX.XXX:45443/ocsinventory>
    COM SERVER => HTTP Post response received <HTTP Status Code #200>
    COM SERVER => Cleaning cURL library
AGENT => Inventory successfully sent
    INVENTORY => Writing new inventory state
AGENT =>  Communication Server asked for Package Download
    DOWNLOAD => Package history file successfully cleaned for duplicate IDs
    DOWNLOAD => Metadata file <info> for package <1554646026> is located at <https://XXX.XXX.XXX.XXXX:45443/download/1554646026/info>
    COM SERVER => Initializing cURL library for getFile
    COM SERVER => Using cURL without server authentication
    COM SERVER => Disabling cURL proxy support
    COM SERVER => Enabling cURL SSL server validation support using CA Bundle <ocsng.pem>
    COM SERVER => Sending fileGet request to URL <https://XXX.XXX.XXX.XXX:45443/download/1554646026/info>
    COM SERVER => fileGet response received <HTTP Status Code #200>
    COM SERVER => Cleaning cURL library
    DOWNLOAD => Unloading communication provider
    DOWNLOAD => Retrieve info file...OK (pack 1554646026)
DOWNLOAD => Package <1554646026> added to download queue
DOWNLOAD => Download and setup tool successfully started
AGENT => Unloading communication provider
AGENT => Unloading plug-in(s)
AGENT => Execution duration: 00:00:41.


Download.log
==============================================================================
Starting OCS Inventory NG Package Download and Setup Tool on Sunday, April 07, 2019 17:31:07.
DOWNLOAD => Running OCS Inventory NG Download Version 2.4.0.0
DOWNLOAD => Using OCS Inventory NG FrameWork Version 2.4.0.0
DOWNLOAD => Using network connection with Communication Server
COM PROVIDER => Loading Communication Provider <C:\Program Files (x86)\OCS Inventory Agent\ComHTTP.dll>
DOWNLOAD => Using Communication Provider <OCS Inventory NG cURL Communication Provider> Version <2.4.0.0>
DOWNLOAD => Starting new period of 10 cycles
DOWNLOAD => Flushing package queue
DOWNLOAD => Parsing directory <C:\ProgramData\OCS Inventory NG\Agent\download> for packages
DOWNLOAD => Verifying package <C:\ProgramData\OCS Inventory NG\Agent\download\1554646026>
ERROR *** DOWNLOAD => Error loading metadata file <C:\ProgramData\OCS Inventory NG\Agent\download\1554646026\info>, removing package <1554646026>
DOWNLOAD => No package found, exiting
DOWNLOAD => Unloading communication provider
DOWNLOAD => Execution duration: 00:00:00.

 


    Nom du système : Linux x86_64
    Version : 4.9.0-8-amd64
    RAM totale : 3937 Mo
    RAM disponible :3376 Mo
    CPU : Intel(R) Xeon(R) CPU E5506 @ 2.13GHz
    Distribution : Debian GNU/Linux 9 (stretch)
    Version de PHP : 7.0.33
    Serveur Web : Apache/2.4.25 (Debian)
    Serveur SQL : Debian 9.6 version 10.1.37-MariaDB-0+deb9u1
    Version OCSReports : 2.6RC
 

answered by (280 points)
edited by
 
Powered by Question2Answer
...