Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.4 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Données manquantes OCS WebService

Bonjour à toutes et à tous,
je suis actuellement en train de développer un outil d'intérogation du WebService d'OCS afin d'utiliser les données.
(Je développe l'outil en C# avec le framework .NET)

Or je suis confronté à un problème.

Mon outil envoit donc une requête SOAP vers le WebService d'OCS mais dans le résultat il manque des machines.
J'ai actuellement 9 machines remontés, mais je ne vois les informations que de 4 machines.

Voici ma requête :

<REQUEST>
   <ENGINE>FIRST</ENGINE>
   <ASKING_FOR>INVENTORY</ASKING_FOR>
   <CHECKSUM>3</CHECKSUM>
    <OFFSET>0</OFFSET>
   <WANTED>0</WANTED>
</REQUEST>

(Je met 3 comme checksum, car les parties qui m'intéresse sont <HARDWARE> et <BIOS>)

Je viens donc vers vous afin de savoir si c'est la requête qui serait éronné ou si je dois revoir mon outil? Dois-je mettre un offset afin d'avoir toutes les données?

Merci pour vos réponses
asked Oct 30, 2014 in Core server development by MeTaLiKiD (200 points)

1 Answer

+1 vote

Bonjour,

Avez-vous jeté un coup d'oeil du côté de votre fichier de conf ocsinventory-server ?

Votre variable PerlSetEnv OCS_OPT_WEB_SERVICE_RESULTS_LIMIT est-elle bien paramétrée?

answered Nov 14, 2014 by J_ULM (1,080 points)
Bonjour,

 

j'ai passé cette variable à 1000, mais je n'ai pas optenu plus de résultats.
 

La valeur représente quoi?

 

Cordialement et merci pour la réponse.
 
Powered by Question2Answer
...