Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.6 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

I can't install ocs plugins

Hy guys,

I'm here again! I have a centos 7 server with ocs inventory server 2.6RC, and I can't install plugins features. I already copied zip file to /usr/share/ocsinventory-reports/ocsreports/download but interface web haven't show me anyone. 

Please, somebody could help me? :)

in OCS Inventory NG server for Unix by (430 points)

3 Answers

+1 vote
 
Best answer

Hi,

- Unzipped zips

- I changed the first letter of the library to uppercase

- rewrite script (install_plugin.py) map.pm to Map.pm

- install (web gui) extensions

- install (shell - python) extensions

Extensions work on the client side, but I experienced this (web gui logon - apache 2 error.log):

[:error] [pid 26185] [client 192.188.242.147:57279] PHP Warning:
 Missing argument 2 for ExtensionHook::addTranslation(), called
 in /usr/share/ocsinventory-reports/ocsreports/require/extensions
/ExtensionHook.php on line 63 and defined in /usr/share/ocsinventory-reports
/ocsreports/require/extensions/ExtensionHook.php on line 244

by (580 points)
selected by
0 votes

Hi,

Have you restart apache ? Do you Have download rework plugin for 2.6RC ? Have you follow this documentation :  http://wiki.ocsinventory-ng.org/10.Plugin-engine/Using-plugins-installer/

Regard.

by (3.6k points)
0 votes

Hi,

since the 2.6 xx version of the OCS server, the plugin copy folder is no longer "download" but

/usr/share/ocsinventory-reports/ocsreports/extensions/


Regards, St├ęphane

by (26.4k points)
 
Powered by Question2Answer
...