Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.8 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

2.8 does not work - downgraded to 2.7

###Server:

PHP Version : 7.4.10
Web Server : Apache/2.4.6 (CentOS) PHP/7.4.10 mod_perl/2.0.11 Perl/v5.16.3
Database Server : MariaDB Server version 5.5.65-MariaDB
Version OCSReports: 2.8

###Agent: 2.8.0.0

###Agent log:

==============================================================================
Starting OCS Inventory Agent on Monday, September 28, 2020 10:37:42.
AGENT => Running OCS Inventory Agent Version 2.8.0.0
AGENT => Using OCS Inventory FrameWork Version 2.8.0.0
AGENT => Loading plug-in(s)
    DLL PLUGIN => Searching for Plug-in DLL(s) in folder <C:\Program Files\OCS Inventory Agent\plugins>
    DLL PLUGIN => 0 DLL Plug-in(s) successfully loaded on 0 DLL(s) found
AGENT => Using network connection with Communication Server
    COM PROVIDER => Loading Communication Provider <C:\Program Files\OCS Inventory Agent\ComHTTP.dll>
AGENT => Using Communication Provider <OCS Inventory cURL Communication Provider> Version <2.8.0.0>
AGENT => Sending Prolog
    DID_CHECK => Read DeviceID <COMPUTER-2020-09-17-08-47-30> and MACs <34:E6:D7:55:00:A700:50:56:C0:00:0100:50:56:C0:00:08D8:FC:93:BC:F8:E4> in file <ocsinventory.dat>
    COM SERVER => Initializing cURL library for sendRequest
    COM SERVER => Using cURL without server authentication
    COM SERVER => Disabling cURL proxy support
    COM SERVER => Disabling cURL SSL server validation support
    COM SERVER => Sending HTTP Post request to URL <http://10.30.2.44/ocsinventory>
    COM SERVER => HTTP Post response received <HTTP Status Code #400>
    COM SERVER => Cleaning cURL library
================= TRACE START ===============

================= TRACE STOP ===============
ERROR *** AGENT => Failed to send Prolog <HTTP Status Code #400>
AGENT => Unloading communication provider
AGENT => Unloading plug-in(s)
AGENT => Execution duration: 00:00:01.

###access.log:

10.30.5.133 - - [28/Sep/2020:10:37:43 +0200] "POST /ocsinventory HTTP/1.1" 400 226 "-" "OCS-NG_WINDOWS_AGENT_v2.8.0.0"
in OCS Inventory NG agent for Windows by (370 points)
edited by

5 Answers

0 votes
Hi,

I have the same problem, I migrated my server to 2.8, my agent 2.6 goes back well against agent 2.8 does not go up (HTTP error 400)
an idea of the problem?

Cirvent
by (500 points)
reshown by
0 votes
I dropped the entire db, downgraded server to 2.7 and agent to 2.7.0.1... now it works... with the bug of software counter =1 of course, but the rest works.
by (370 points)
0 votes
Hi

How had you installed ocs server before upgrade from 2.6 or 2.7 to 2.8 ?

Regards

Frank
by (79.8k points)
0 votes
Always from the sources, with setup.sh.
by (370 points)
0 votes

hello,

I made an update from version 2.6,with the setup.sh

Cirvent

by (500 points)
 
Powered by Question2Answer
...