Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.8 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Impossible d'activer paquet télédéploiement [closed]

Bonjour,

Je n'arrive pas à activer mes paquets pour le télédéploiement, j'obtiens le message d'avertissement:

ATTENTION: Le fichier d'information est introuvable à l'adresse https://server/download/1405949525/

Etes-vous sûr de vouloir tout de même activer le paquet avec ces paramètres ?

J'ai pourtant bien accès au répertoire https://server/download mais il est actuellement vide.

Pouvez-vous m'aider?

Cordialement
closed with the note: Problème résol
in OCS Inventory NG server for Unix by (1.4k points)
closed by

5 Answers

0 votes
je pense que tu as du mal configurer le répertoire download. Il faut absoluement que la configuration que tu mets dans l'espace de configuration d'OCSreports soit la même que dans le fichier ocsinventory-server.conf.
by (21.7k points)
0 votes
Alors en fait quand je crée un paquet il me dit bien:

Votre paquet a bien été créé dans le répertoire /var/lib/ocsinventory-reports/download/1407229410

Je vais en ligne de commande dans le répertoire et le dossier n'apparaît pas. Donc c'est pour ca que je ne peux pas l'activer ensuite.

J'ai créé un fichier bidon dans /var/lib/ocsinventory-reports/download et quand je vais à l'adresse https://server/download je vois bien mon fichier.

Dans la configuration du télédéploiement; j'ai bien mis http://server/download et https://server/download
 dans les deux variables.

Je ne comprends pas d'où vient le problème. Pouvez-vous m'aider?

Merci
by (1.4k points)
Tu as quoi dans la configuration apache ? (aka ocsinventory-server.conf)
Mon fichier se nomme ocsinventory-reports.conf en fait. La partie download qui nous interresse contient ça:

Alias /download /var/lib/ocsinventory-reports/download

<Directory /var/lib/ocsinventory-reports/download>
    # By default, users can use console from everywhere
    Order deny,allow
    Allow from all
    Options Indexes FollowSymLinks
    DirectoryIndex index.php
    AllowOverride Options
</Directory>
Regardes si les droits sont bon sur /var/lib/ocsinventory-reports/download
Bonjour,

C'est du 777 sur le répertoire download avec apache:apache comme propriétaire
Tu as quoi comme distribution ?
J'utilise Redhat 5.10
–1 vote
Bonjour,

if you have php 5.6.x installed and you use a self signed certificate, php doesn't accept the cert anymore.

That php accept your cert you can edit the option "openssl.cafile" in your php.ini.

Example:

[openssl]

openssl.cafile=/etc/apache2/ssl/ocs.pem
by (120 points)
The agent is writen in C or perl (depend of the agent) and the directory is given by apache (nothing do by php).
When i understand the question right, he wants to activate a package in the web interface. This has nothing to do with the agent. The activation of a package is done by a php script. In the script there is an fopen-call which doesn't accept self-signed certs.
0 votes
Bonjour,

Je suis en RHEL 5.10

Mes certificats ne sont pas auto-signés.

Avez-vous des pistes?
by (1.4k points)
0 votes
Bonjour,

Je viens de tester ce matin ca fonctionne!

Je n'arrive pas à comprendre ce qui n'allait pas. Du coup dans le doute, j'ai laissé les permissions en 777.

Merci
by (1.4k points)
 
Powered by Question2Answer
...