Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.6 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

403 Forbidden

You don't have permission to access /ocsreports/ on this server.

After that error i installed ocsinventory new. But that error still happen. Other sites in /var/www working. Some ideas?
asked in OCS Inventory NG server for Unix by (270 points)

4 Answers

0 votes
Hi,

Try with https:://@ip_ocs_server/ocsreports/, maybe your server accepts only https access.
answered by (70.3k points)
0 votes
After reinstall, set you back the password of ocs-user in this files to ocs?

.. html/xyz/ocsreports/dbconfig.inc.php
.. httpd/conf.d/z-ocsinventury-server.conf
answered by (180 points)
0 votes
Hi,

Had the same problem after a fresh installation, and you will also have problem with the download section.

Solution is:

1. Edit /etc/apache2/modules.d/ocsinventory-reports.conf (wherever it's located for you) to match the following (NB. DO NOT COPY PASTE !!! as I removed some parts specific to my server -> just match those directives)

[code]
Alias /ocsreports /usr/share/ocsinventory-reports/ocsreports

<Directory /usr/share/ocsinventory-reports/ocsreports>
    # By default, users can use console from everywhere
    Order deny,allow
    Allow from all
    Options Indexes FollowSymLinks
    DirectoryIndex index.php
    AllowOverride Options
</Directory>
Alias /download /var/lib/ocsinventory-reports/download

<Directory /var/lib/ocsinventory-reports/download>
    # By default, users can use console from everywhere
    Order deny,allow
    Allow from all
    Options Indexes FollowSymLinks
    DirectoryIndex index.php
    AllowOverride Options
</Directory>
[/code]
 

2. Verify that apache user can access the alias directories, if needed, chown and chmod these directories (recursively) or set the correct permissions, if running on windows

Hope I did not forgot something :-) Good luck !

behd
answered by (280 points)
0 votes

Try this solution

https://askubuntu.com/a/601722/392041

basically just replace

Order allow,deny
allow from all

with

Require all granted
answered by (250 points)
 
Powered by Question2Answer
...