Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.6 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Problèmes de remontée de poste

Bonjour,

 

Actuellement stagiaire dans une école agroalimentaire, je dois mettre en place un GLPI/OCS. Je réalise des tests sur une machine physique sous Windows 7 (pour le serveur) et une machine virtuelle sous XP ou la même machine physique (pour l'agent).

 

La machine physique et la machine virtuelle arrivent à se communiquer via un ping. Mais quand je fais depuis l'agent : "Exécuter l'agent OCS Inventory OCS Inventory NG maintenant". Il me dit qu'il a bien envoyé les informations. Mais je n'ai aucune remonté quand je fais : "Importation de nouveaux ordinateurs". Il me répond tout simplment : "Pas de nouvel ordinateur à importer".

De plus, j'ai cette nouvelle erreur là : "Impossible de démarrer le programme car il manque perl58.dll sur votre ordinateur. Essayez de réinstaller le programme pour corriger ce problème.".

 

Voici les informations de mon fichier de "log" sous ma machine XP :

==============================================================================
Starting OCS Inventory NG Agent on Monday, February 09, 2015 10:20:12.
AGENT => Running OCS Inventory NG Agent Version 2.1.1.1
AGENT => Using OCS Inventory NG FrameWork Version 2.1.1.1
AGENT => Loading plug-in(s)
AGENT => Using network connection with Communication Server
AGENT => Using Communication Provider <OCS Inventory NG cURL Communication Provider> Version <2.1.1.1>
AGENT => Sending Prolog
ERROR *** AGENT => Failed to send Prolog <HTTP Status Code #404>
AGENT => Unloading communication provider
AGENT => Unloading plug-in(s)
AGENT => Execution duration: 00:00:00.

==============================================================================
Starting OCS Inventory NG Agent on Monday, February 09, 2015 10:21:50.
AGENT => Running OCS Inventory NG Agent Version 2.1.1.1
AGENT => Using OCS Inventory NG FrameWork Version 2.1.1.1
AGENT => Loading plug-in(s)
AGENT => Using network connection with Communication Server
AGENT => Using Communication Provider <OCS Inventory NG cURL Communication Provider> Version <2.1.1.1>
AGENT => Sending Prolog
ERROR *** AGENT => Failed to send Prolog <HTTP Status Code #404>
AGENT => Unloading communication provider
AGENT => Unloading plug-in(s)
AGENT => Execution duration: 00:00:01.

==============================================================================
Starting OCS Inventory NG Agent on Monday, February 09, 2015 10:25:08.
AGENT => Running OCS Inventory NG Agent Version 2.1.1.1
AGENT => Using OCS Inventory NG FrameWork Version 2.1.1.1
AGENT => Loading plug-in(s)
AGENT => Using network connection with Communication Server
AGENT => Using Communication Provider <OCS Inventory NG cURL Communication Provider> Version <2.1.1.1>
AGENT => Sending Prolog
ERROR *** AGENT => Failed to send Prolog <HTTP Status Code #404>
AGENT => Unloading communication provider
AGENT => Unloading plug-in(s)
AGENT => Execution duration: 00:00:00.

==============================================================================
Starting OCS Inventory NG Agent on Monday, February 09, 2015 10:26:50.
AGENT => Running OCS Inventory NG Agent Version 2.1.1.1
AGENT => Using OCS Inventory NG FrameWork Version 2.1.1.1
AGENT => Loading plug-in(s)
AGENT => Using network connection with Communication Server
AGENT => Using Communication Provider <OCS Inventory NG cURL Communication Provider> Version <2.1.1.1>
AGENT => Sending Prolog
ERROR *** AGENT => Failed to send Prolog <HTTP Status Code #404>
AGENT => Unloading communication provider
AGENT => Unloading plug-in(s)
AGENT => Execution duration: 00:00:00.

==============================================================================
Starting OCS Inventory NG Agent on Monday, February 09, 2015 10:37:47.
AGENT => Running OCS Inventory NG Agent Version 2.1.1.1
AGENT => Using OCS Inventory NG FrameWork Version 2.1.1.1
AGENT => Loading plug-in(s)
AGENT => Using network connection with Communication Server
AGENT => Using Communication Provider <OCS Inventory NG cURL Communication Provider> Version <2.1.1.1>
AGENT => Sending Prolog
ERROR *** AGENT => Failed to send Prolog <HTTP Status Code #404>
AGENT => Unloading communication provider
AGENT => Unloading plug-in(s)
AGENT => Execution duration: 00:00:00.

 

Et le fichier ".ini" :
 
[OCS Inventory Agent]
ComProvider=ComHTTP.dll
Debug=0
Local=
NoSoftware=0
HKCU=0
NoTAG=0
IpDisc=
[HTTP]
Server=http://10.39.30.34/ocsinventory-server
SSL=1
CaBundle=cacert.pem
AuthRequired=0
User=ocs
Pwd=ocs
ProxyType=0
Proxy=
ProxyPort=0
ProxyAuthRequired=0
ProxyUser=
ProxyPwd=
[OCS Inventory Service]
TTO_WAIT=1800
 
 
 
 
A votre avis, d'où vient le problème ?
 
Je vous remercie par avance et en attente de de vos futures réponses.
 
Cordialement,
 
Zakira,
in OCS Inventory NG server for Windows by (160 points)

4 Answers

0 votes

Bonjour

Server=http://10.39.30.34/ocsinventory-server <= il faut mettre ocsinventory 
SSL=1 <= mettre 0 

Arrêter le service ocsinventory, puis modifier le fichier ocsinventory.ini, sauvegarder, démarrer le service ocsinventory et refaire un inventaire.

Cordialement

Frank

by (70.6k points)

J'ai fait les changements mais il y a toujours aucune remontée.

J'ai toujours ce message d'erreur dans le fichier de log :

 

ERROR *** AGENT => Failed to send Prolog <HTTP Status Code #500>

 

De plus j'ai ces erreurs quand je vais dans "http://localhost/ocsreports/index.php" : 

 

  • The default SQL login/password is activate on your database: ocsweb
  • The default login/password is activate on OCS-NG GUI

Est-ce que ces erreurs sont-elles importantes pour le problème de remontée ?

 

Cordialement,

 

Zakira,

 

------------------------------------------------------------------------------------------------

 

Là j'ai une autre erreur :

 

ERROR *** AGENT => Failed to send Prolog <HTTP Status Code #404>

Bonne nouvelle je n'ai plus l'erreur 400 en mettant ceci dans l'agent :

 

Server=http://10.39.30.34:8080/ocsinventory

 

Mais toujours aucune remontée...

0 votes

J'ai fait les changements mais il y a toujours aucune remontée.

J'ai toujours ce message d'erreur dans le fichier de log :

 

ERROR *** AGENT => Failed to send Prolog <HTTP Status Code #500>

 

De plus j'ai ces erreurs quand je vais dans "http://localhost/ocsreports/index.php" : 

 

  • The default SQL login/password is activate on your database: ocsweb
  • The default login/password is activate on OCS-NG GUI
Est-ce que ces erreurs sont-elles importantes pour le problème de remontée ?
 
Cordialement,
 
Zakira,
by (160 points)
0 votes
Bonjour,

merci de poster le contenu du ifchier error.log d'apache.

Cordialement

Frank
by (70.6k points)
0 votes
Bonjour Zak,

Lorsque tu te connectes à ton serveur OCS tu utilises quelle adresse dans ton navigateur (http://ip_du_serveur/ocsreports ou http://ip_du_serveur:8080/ocsreports ?

Au niveau de l'agent il faut la même chose en remplaçant le ocsreports par ocsinventory

 

Au niveau de l'agent il n'y pas d'authentification à mettre laisse les lignes du fichier de config de l'agent comme ceci

User=
Pwd=

Pour modifier le fichier il faut bien arrêter l'agent au niveau des services windows, puis le redémarrer parès les modifications.

Tiens nous au courant.
by (1.1k points)
 
Powered by Question2Answer
...