Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.8 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

SNMP marche pas

Bonjour,

après avoir suivi les tutos du wiki pour le certificat SSL et comment activer SNMP sur le serveur, j'ai installer le client OCS sur une debian 7.

Cependant lorsque je lance ocsinventory-agent, mon agent scan le reseau sous la forme suivante :

[Fri Feb 13 10:34:55 2015][debug] [snmp] Found ADDRIP
[Fri Feb 13 10:34:55 2015][debug] [snmp] Found ADDRIP
[Fri Feb 13 10:35:41 2015][debug] [snmp] Found ADDRIP
[Fri Feb 13 10:35:57 2015][debug] [snmp] Found ADDRIP
[Fri Feb 13 10:35:58 2015][debug] [snmp] Found ADDRIP
[Fri Feb 13 10:36:02 2015][debug] [snmp] Found ADDRIP
[Fri Feb 13 10:36:06 2015][debug] [snmp] Found ADDRIP
[Fri Feb 13 10:36:07 2015][debug] [snmp] Found ADDRIP
[Fri Feb 13 10:36:07 2015][debug] [snmp] Found ADDRIP

Ensuite, me met cela :

[Fri Feb 13 10:48:37 2015][debug] [snmp] Scanning ADDRIP device
[Fri Feb 13 10:48:55 2015][debug] [snmp] Failure in scanning Device ADDRIP: no snmp communication
[Fri Feb 13 10:48:55 2015][debug] [snmp] Scanning ADDRIP device
[Fri Feb 13 10:49:13 2015][debug] [snmp] Failure in scanning Device ADDRIP: no snmp communication
[Fri Feb 13 10:49:13 2015][debug] [snmp] Scanning ADDRIP device
[Fri Feb 13 10:49:31 2015][debug] [snmp] Failure in scanning Device ADDRIP: no snmp communication
[Fri Feb 13 10:49:31 2015][debug] [snmp] Scanning ADDRIP device
[Fri Feb 13 10:49:49 2015][debug] [snmp] Failure in scanning Device ADDRIP: no snmp communication
[Fri Feb 13 10:49:49 2015][debug] [snmp] Scanning ADDRIP device
[Fri Feb 13 10:50:07 2015][debug] [snmp] Failure in scanning Device ADDRIP: no snmp communication
[Fri Feb 13 10:50:07 2015][debug] [snmp] Scanning ADDRIP device
[Fri Feb 13 10:50:25 2015][debug] [snmp] Failure in scanning Device ADDRIP: no snmp communication

j'ai aussi des messages comme cela dans le log :

[Fri Feb 13 10:54:56 2015][debug] [snmp] Running HP (11) MIB module
[Fri Feb 13 10:54:56 2015][debug] [snmp] Launching If_Mib
[Fri Feb 13 10:54:56 2015][debug] [snmp] Running If MIB module

[Fri Feb 13 10:53:37 2015][debug] [snmp] Launching Default
[Fri Feb 13 10:53:37 2015][debug] [snmp] Running Default MIB module
[Fri Feb 13 10:53:37 2015][debug] [snmp] Launching If_Mib
[Fri Feb 13 10:53:37 2015][debug] [snmp] Running If MIB module
[Fri Feb 13 10:53:37 2015][debug] [snmp] Launching Printer_Mib

 

Je ne sais pas trop a  quoi cela correspond, on dirai que le SNMP marche pas bien, car je n'ai aucunes remontés, enfin j'ai juste eu 2 serveurs de remonté (je ne sais pas trop pourquoi) et depuis plus rien. Ce qui m'interesse est surtout les imprimantes

Si vous pouvez m'aider... Merci à vous

Bonne journée
in OCS Inventory NG agent for Unix by (200 points)

1 Answer

0 votes

Bonjour,

[Fri Feb 13 10:48:37 2015][debug] [snmp] Scanning ADDRIP device
[Fri Feb 13 10:48:55 2015][debug] [snmp] Failure in scanning Device ADDRIP: no snmp communication

Ces messages indiquent que le protocole SNMP n'est pas activé sur l'adresse IP scannée. Que donne la commande suivante => snmpwalk -c public -v 2c @ip

Cordialement

Frank

by (79.6k points)
 
Powered by Question2Answer
...