Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.6 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Tag not being filled

Hi,

I'm installing windows agent via gpo, using packager tool, it is working perfectly.

Now, I've generated a new OcsPackage.exe with packager tool again, changing some parameters. One of them is TAG, I've put /TAG=XXX. What's the problem? If computer is new, it works perfectly, Tag is being filled and showed in the ocsreports website. The problem comes when computer has the before agent installed, new agent is installed, because I've put /force parameter, it is ok, but tag is not being filled (I can't see it filled in the ocsreports website).

If I delete computer entry in the ocsreports website, it works perfectly too, tag is being filled in that case.

How could I fix this? Without deleting entries in the ocsreports website.

Thanks beforehand.

Regards...
in OCS Inventory NG agent for Windows by (210 points)

1 Answer

0 votes
Hi,

Use  OCS_OPT_ACCEPT_TAG_UPDATE_FROM_CLIENT to 1 in z-ocsinventory-server.conf file. Then restart apache after modifications.

Regards
by (70.8k points)
Thank you very much, but it isn't working :-( I've done the changes that you have said me and restarting apache.

It only works if I delete computer entry before reinstalling agent with new parameters (including tag parameter).

I'm passing the next parameters to agent in the packager tool:

/S /server=http://IP/ocsinventory /ssl=0 /debug=0 /tag=XXXXX /nosplash /notag

And the next parameters to ocslogon:

/PACKAGER /GPO /DEPLOY=2.1.1.1 /FORCE /SERVER=http:/IP/ocsinventory

Thanks beforehand.
 
Powered by Question2Answer
...