Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.6 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Problème d'installation module Apache2::SOAP

Bonjour tout le monde,

Lors de l'installation d'OCS inventory version 2.1.2, j'ai constaté un problème :

Checking for Apache2::SOAP PERL module...
*** Warning: PERL module Apache2::SOAP is not installed !
This module is only required by OCS Inventory NG SOAP Web Service.

Pour tenter de résoudre le problème, j'ai voulu installer le module via la commande : perl -MCPAN -e 'install Apache2::SOAP'. Finalement, je me suis rendu compte qu'il était déjà installé :

Going to read '/root/.cpan/Metadata'
 Database was generated on Mon, 11 Aug 2014 14:29:02 GMT
Apache2::SOAP is up to date (0.73).

Sur l'ancien forum, j'ai trouvé une conversation (id=13797)  ou la personne expose le même problème que moi. Vous lui avez répondu (le 15/04/2014) que ça ne gêne pas le bon fonctionnement d'OCS  et que vous alliez plancher sur la question.

Question : L'avez-vous résolu ou le problème est-t-il toujours d'actualité ? J'aimerai être sûr que le problème ne vient pas de chez moi.

D'avance merci.

in OCS Inventory NG server for Unix by (1.1k points)

6 Answers

0 votes
Bonjour,

Quel est l'OS du serveur? Quelle est la version d'OCS?
by (70.6k points)

Bonjour,

  • Debian Wheezy 7.6
  • OCS  : OCSNG_UNIX_SERVER-2.1.2
J'ai le meme probleme, meme OS et version d'OCS que J_ULM.

J'ai eu ce probleme aussi avec la version 2.0.1 du server mais le system a toujours fonctionnè perfectement, donc quelle est exactement l'utilitè de ce module dans l'OCS?

Merci beaucoup
Pour ma part, je cherchais à conceptualiser la base de données OCS en modéle MCD afin d'écrire de façon formelle les données qui seront utilisées par OCS. Nous avions besoin d'une représentation des données, facilement compréhensible, afin d'effectuer des comparaisons avec nos autres bases de données (dans un but interopérabilité).

Finalement, j'ai vu qu'OCS inventory avait du SOAP pour tout ce qui est  intéropérabilité entre les bases de données. Du coup, nous nous orientons vers cette solution.

En voyant ce message d'erreur, je me suis donc inquiété.
0 votes
Hi,

I met the same problem : I have already installed the module( Apache2::SOAP) ,  but it still sign me "not installed".

Have you already solved it ?

 

OS :  Redhat 5.5

OCS Server:     OCSNG_UNIX_SERVER-2.1.2
by (140 points)
+1 vote
Le problème est connu et c'est de la faute de debian : debian ne veut pas packager les dépendances nécessaire à OCS pour le SOAP donc du coup le SOAP n'est pas disponible.

La meilleurs des solutions est simplement d'utiliser une centos qui fonctionne très bien et qui possède en plus des packages OCS à jour via les dépots de Remi Collet.
by (21.2k points)
0 votes
Bonjour,

Merci Kapouik pour cette information qui pour moi est importante ! Si  j'ai bien compris, je dois migrer sur des machines CentOS pour pouvoir utiliser comme il se doit le protocole SOAP avec OCS inventory.
by (1.1k points)
0 votes

Bonjour,

Malgré la migration vers CENTOS 7.0, j'ai toujours le même problème :

Checking for Apache2::SOAP PERL module...
*** Warning: PERL module Apache2::SOAP is not installed !
This module is only required by OCS Inventory NG SOAP Web Service.

Dans le doute, j'ai annulé l'installation d'OCS inventory puis réinstallé le paquet Apache 2 via la commande :  yum install apache2::SOAP

Ceci n'a pas résolu le problème. J'ai besoin du paquet pour pouvoir intérroger la base OCS inventory.

Auriez-vous une solution à me proposer ? Je n'arrive pas à savoir si le problème vient de l'outil OCS ou de mon installation.

PS : j'ai installé la dernière version d'OCS : 2.1.2

by (1.1k points)
0 votes

J'ai le même problème sur une redhat 5.7 alors que la paquet est installé

# yum list perl-*SOAP*
Loaded plugins: rhnplugin, security
This system is receiving updates from RHN Classic or RHN Satellite.
Installed Packages
perl-Apache2-SOAP.noarch                                           0.73-1.el5                                             installed
perl-SOAP-Lite.noarch                                              0.712-5.el5                                            installed

by (230 points)
 
Powered by Question2Answer
...