Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.5 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Pb remontée information réseau AIX 7.1 [closed]

Bonjour à tous!

Mon parc machine est composé entre autres de machines en OS AIX 7.1

La remontée des informations se fait bien sauf pour une machine où je n'ai pas les informations de la carte réseau.

En exécutant l'agent en mode debug, j'ai repéré ceci:

"[Tue Aug  4 18:56:52 2015][debug] Ocsinventory::Agent::Backend::OS::AIX::Networks ignored"

Pourquoi ce module est-il ignoré?

Comment puis-je corriger ceci?

Merci pour votre aide.
closed with the note: Problème résolu
asked in OCS Inventory NG agent for Unix by (260 points)
closed by

8 Answers

0 votes
Bonjour,

Est-ce que tous les paquets perl nécessaires sont bien installés sur la machine AIX?

Cordialement

Frank
answered by (61.6k points)
0 votes
Il y a exactement les mêmes modules Perl installés sur les machines qui remontent bien les informations ainsi que sur celle qui pose problème, soit:

Installed modules are:
   Crypt::SSLeay
   Digest
   HTML::Parser
   HTML::Tagset
   IO::Socket::INET6
   MIME::Base64
   Ocsinventory::Unix::Agent
   Perl
   Socket6
   URI
   XML::LibXML
   XML::LibXML::Common
   XML::NamespaceSupport
   XML::Parser
   XML::SAX
   XML::Simple
   libwww-perl
answered by (260 points)
0 votes
Bonjour,

Peux-tu poster le contenu du fichier ocsinventory-agent.log, stp ou du moins les 50 premières lignes?

Merci

Cordialement

Frank
answered by (61.6k points)
0 votes
Bonjour,

"[Tue Aug  4 18:56:52 2015][debug] Ocsinventory unified agent for UNIX, Linux and MacOSX 2.1.1
[Tue Aug  4 18:56:52 2015][debug] Log system initialised (File)
[Tue Aug  4 18:56:52 2015][debug] --scan-homedirs missing. Don't scan user directories
[Tue Aug  4 18:56:52 2015][debug] Accountinfo file: /var/lib/ocsinventory-agent/http:__10.167.1.160_ocsinventory/ocsinv.adm
[Tue Aug  4 18:56:52 2015][debug] OCS Agent initialised
[Tue Aug  4 18:56:52 2015][debug] Turns hooks on for /etc/ocsinventory-agent/modules.conf
[Tue Aug  4 18:56:52 2015][debug] Ocsinventory unified agent for UNIX, Linux and MacOSX 2.1.1
[Tue Aug  4 18:56:52 2015][debug] Log system initialised (File)
[Tue Aug  4 18:56:52 2015][debug] Calling handlers : `start_handler'
[Tue Aug  4 18:56:52 2015][debug] [download] Calling download_start_handler
[Tue Aug  4 18:56:52 2015][debug]  - LWP loaded
[Tue Aug  4 18:56:52 2015][debug]  - Crypt::SSLeay loaded
[Tue Aug  4 18:56:52 2015][debug] Compress::Zlib is available.
[Tue Aug  4 18:56:52 2015][debug] Calling handlers : `prolog_writer'
[Tue Aug  4 18:56:52 2015][debug] sending XML
[Tue Aug  4 18:56:52 2015][debug] sending: <?xml version="1.0" encoding="UTF-8"?>
<REQUEST>
  <QUERY>PROLOG</QUERY>
  <DEVICEID>E03-PR-V1-GED01-2015-08-04-14-21-05</DEVICEID>
</REQUEST>
[Tue Aug  4 18:56:52 2015][debug] =BEGIN=SERVER RET======
[Tue Aug  4 18:56:52 2015][debug] $VAR1 = '<?xml version=\'1.0\' encoding=\'UTF-8\'?>
<REPLY>
  <OPTION>
    <NAME>REGISTRY</NAME>
    <PARAM NAME="SNMP" REGKEY="SYSTEM\\CurrentControlSet\\Services\\SNMP" REGTREE="2">Start</PARAM>
  </OPTION>
  <OPTION>
    <NAME>DOWNLOAD</NAME>
    <PARAM FRAG_LATENCY="10" PERIOD_LATENCY="1" ON="1" TYPE="CONF" CYCLE_LATENCY="60" TIMEOUT="30" PERIOD_LENGTH="10" EXECUTION_TIMEOUT="120" />
  </OPTION>
  <RESPONSE>SEND</RESPONSE>
  <PROLOG_FREQ>24</PROLOG_FREQ>
</REPLY>
';
[Tue Aug  4 18:56:52 2015][debug] =END=SERVER RET======
[Tue Aug  4 18:56:52 2015][debug] PROLOG_FREQ has not changed since last process
[Tue Aug  4 18:56:52 2015][info] No support detected. Registration key: N/A
[Tue Aug  4 18:56:52 2015][debug] Calling handlers : `prolog_reader'
[Tue Aug  4 18:56:52 2015][debug] [download] Calling download_prolog_reader
[Tue Aug  4 18:56:52 2015][debug] [download] <?xml version='1.0' encoding='UTF-8'?>
<REPLY>
  <OPTION>
    <NAME>REGISTRY</NAME>
    <PARAM NAME="SNMP" REGKEY="SYSTEM\CurrentControlSet\Services\SNMP" REGTREE="2">Start</PARAM>
  </OPTION>
  <OPTION>
    <NAME>DOWNLOAD</NAME>
    <PARAM FRAG_LATENCY="10" PERIOD_LATENCY="1" ON="1" TYPE="CONF" CYCLE_LATENCY="60" TIMEOUT="30" PERIOD_LENGTH="10" EXECUTION_TIMEOUT="120" />
  </OPTION>"
answered by (260 points)
0 votes
Bonjour,

Désolé pour la réponse tardive.

Il manque le paquet Net::IP. Sans ce paquet les infos réseau ne sont pas inventoriées.

Cordialement

Frank
answered by (61.6k points)
0 votes
Bonjour,

J'ai le même problème sur Debian. J'ai installé l'agent avec apt-get, puis j'ai suivi le wiki de configuration. J'ai bien installé Net::IP avec CPAN (je le trouve dans cpan -l) mais pas dans instmodsh l.

J'ai du manquer quelque chose, car dans mon ocs.log, le section <NETWORKS> reste vide.

Merci de votre aide.
answered by (220 points)
0 votes
Bonjour,

Il faut les deux commandes ip et ifconfig pour remonter les infos réseau sur Debian. C'est un bug qui a été corrigé dernièrement.
Cordialement

Frank
answered by (61.6k points)
0 votes
Merci,

J'avais bien déjà installé manuellement le package ifconfig. J'ai finalement résolu mon problème en prenant le .tar.gz sur github. La version sur apt-get était la 2.0.5 qui n'est pas à jour. Et cela fonctionne à présent. Merci.
answered by (220 points)
 
Powered by Question2Answer
...