Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.6 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

OCS AGENT Failed to send Prolog-HTTP Status Code #404>

==============================================================================
Starting OCS Inventory NG Agent on Tuesday, January 12, 2016 10:03:21.
AGENT => Running OCS Inventory NG Agent Version 2.1.1.1
AGENT => Using OCS Inventory NG FrameWork Version 2.1.1.1
AGENT => Loading plug-in(s)
AGENT => Using network connection with Communication Server
AGENT => Using Communication Provider <OCS Inventory NG cURL Communication Provider> Version <2.1.1.1>
AGENT => Sending Prolog
ERROR *** AGENT => Failed to send Prolog <HTTP Status Code #404>
AGENT => Unloading communication provider
AGENT => Unloading plug-in(s)
AGENT => Execution duration: 00:00:00.

Hi All,

I installed OCS server 2.1. on Centos 6.5x64 then I installed OCS Agent 2.1.1.1 on Windows 7 PC but when try to communicate agent with OCS server getting an error like this (ERROR *** AGENT => Failed to send Prolog <HTTP Status Code #404>). Kindly help me to sort it out this error.

Also want to mention I did not installed mod_perl package because when it installed httpd not starting.

in OCS Inventory NG agent for Windows by (120 points)

2 Answers

0 votes
Hi,

Without mod_perl ocs server can't run correctly. Inventories are sent to ocs server on /ocsinventory url which NEEDS mod_perl. Which error have you when you setup mod_perl with http on your ocs server?

Regards

Frank
by (70.3k points)

Hi,

Thanks for the replay, when I setup mod_perl unable to start httpd that mean service start failed.

Hello , I have the same problem but I have the server installed on windows . The perl module is installed. Any ideas?

0 votes

hi,

Try to access http://yourocsIP/ocsinventory . If the result show 400 bad request => your mod perl are configured ok.

Then move these files:

#mv /etc/apache2/conf-available/ocsinventory-reports.conf /etc/apache2/sites-enabled/

#mv /etc/apache2/conf-available/z-ocsinventory-server.conf /etc/apache2/sites-enabled/

Restart apache2 service

# /etc/init.d/apache2 restart

Hope it help!

by (380 points)
 
Powered by Question2Answer
...