Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.6 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Windows Agent can't connect to Server

I install agents in both Linux and Windows but only Linux is work properly. So I open debug mode and see the log.

The environments are 1.Latest agent 2. Windows Server 2008 R2 Enterprise.

These line below is what I found in log file.

Starting OCS Inventory NG Agent on Tuesday, August 26, 2014 13:26:03.
AGENT => Running OCS Inventory NG Agent Version 2.1.1.1
AGENT => Using OCS Inventory NG FrameWork Version 2.1.1.1
AGENT => Loading plug-in(s)
 DLL PLUGIN => Searching for Plug-in DLL(s) in folder <C:\Program Files (x86)\OCS Inventory Agent\plugins>
 DLL PLUGIN => 0 DLL Plug-in(s) succesfully loaded on 0 DLL(s) found
AGENT => Using network connection with Communication Server
 COM PROVIDER => Loading Communication Provider <C:\Program Files (x86)\OCS Inventory Agent\ComHTTP.dll>
AGENT => Using Communication Provider <OCS Inventory NG cURL Communication Provider> Version <2.1.1.1>
AGENT => Sending Prolog
 DID_CHECK => Read DeviceID <W2K8R2ORCL-0282-2014-07-03-14-23-57> and MACs <00:50:56:01:0D:A3> in file <ocsinventory.dat>
 COM SERVER => Initializing cURL library for sendRequest
 COM SERVER => Using cURL without server authentication
 COM SERVER => Disabling cURL proxy support
 COM SERVER => Disabling cURL SSL server validation support
 COM SERVER => Sending HTTP Post request to URL <http://10.234.109.102/ocsinventory>
 WARNING * COM SERVER => Failed to send HTTP Post request <Couldn't connect to server>
 COM SERVER => Cleaning cURL library
================= TRACE START ===============

================= TRACE STOP ===============
ERROR * AGENT => Failed to send Prolog <Couldn't connect to server>
AGENT => Unloading communication provider
AGENT => Unloading plug-in(s)
AGENT => Execution duration: 00:00:02.

What is the solution of this problem?

in OCS Inventory NG agent for Windows by (210 points)

2 Answers

0 votes

You tested ping or telnet on port 80?

 

by (220 points)
0 votes
Hi,

Verify in ocsinventory.ini file that SSL variable is set to 0. If not, set to 0, save file and restart ocs service. Before making changes, stop service.
by (73.3k points)
Hi, IT's not work. However, do you any idea to fix this issue. Thanks.
 
Powered by Question2Answer
...