Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.6 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Is there any problem with 2.0.5 Server/agent and SNMP?

Hello team,

Before all, thanks for your great job developing such a great tool as a OCS inventory.

We are a big company with a huge network divided in a multiple subnets, and we've just installed the VMDK OCS-NG-Server-2.0.5-CentOS-6.2-64bits.tar version and a client Ocsinventory-Unix-Agent-2.0.5.tar to make some tests and everything is fine except two important points.

1 . The SNMP scan does'nt works. We have configured well all the parameters, we are reaching the machines ( proving it due "snmpwalk -v 1 -c XXXX 10.194.97.41" and we have feedback. We've checked our firewall parameters and they're right as well. Aditionally, we've activated the SNMP function in /etc/ocsinventory/modules.conf . Here's the ocsinventory-agent debug:

[debug] =END=SERVER RET======
[debug] Calling handlers : `end_handler'
[debug] [snmp] Calling snmp_end_handler
[debug] [download] Calling download_end_handler
[info] [download] Beginning work. I am 4157.
[info] [download] No more package to download.
[debug] [download] End of work...

So, is there any problem with 2.0.5 Server/Agent versions and SNMP?

2- As we attach at the image, we can't configure a specific SNMP_NETWORK over the OCS Unix Agent. ( In your documentation you show other options: http://wiki.ocsinventory-ng.org/index.php/File:EN_ocsreports_snmp_computer_custom_parameters.png )

Any solution?

Thank you in advance

in SNMP by (140 points)

2 Answers

0 votes
There is many improvement in latest version : please update
by (20.4k points)
We've installed the latest versións and we have the same issue with SNMP:

Server versión: OCSNG_UNIX_SERVER-2.2

Agent version: Ocsinventory-Unix-Agent-2.1.1

Please, we need help to keep working on it.
0 votes
I would suggest electing a subnet in the IPDISCOVER drop down, setting SNMP_SWITCH to ON for the screenshot provided

Additionally, on server configuration setting SNMP to "ON"
by (490 points)

It's not working even with the parameters you suggest. IPDiscover function is working fine, but not the SNMP option

Try add the netmask for the snmp_network: 10.194.79.0/24 for example
We've added the Netmask ( 10.194.79.0/24 ) and the SNMP function is not working.

Please, it's important to be resolved and we need your support. Just to remind you: we've configured well all the parameters and we are reaching the machines ( proving it due "snmpwalk -v 1 -c XXXX 10.194.97.41" and we have feedback. We've checked our firewall parameters and they're right as well. Aditionally, we've activated the SNMP function in /etc/ocsinventory/modules.conf and all the libraries are installed.

Thank you in advance
Please, we need your support..
Hi,

Is 24 your netmask?

Have you configured the communities?

Have you configured SSL in the server?

Have you copied the certificate file to the client?

You can execute the agent with --debug option to see more information.

http://wiki.ocsinventory-ng.org/index.php/Documentation:SNMP
 
Powered by Question2Answer
...