Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.6 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Server error when client send information

-------------------------------------------------English-------------------------------------------------

Hey guys !

I've installed OCS on a new virtual Server. I completed the install easily, but now i can't receive data from Client.

In my Client log i found that :

[/NOW] used, so launching "C:\Program Files (x86)\OCS Inventory Agent\ocsinventory.exe"...Result: 4

I checked twice, the Server IP is correct.

In my "error.log" on my Debian Server i can find that :

[Wed Jun 01 09:45:11.527135 2016] [perl:error] [pid 17035] [client 192.168.225.100:51879] Can't call method "do" on an undefined value at /usr/local/share/perl/5.20.2/Apache/Ocsinventory/Server/System.pm line 177.\n

And in the file System.pm we can see :

175:  my $dbh = DBI->connect("DBI:mysql:database=$database;host=$host;port=$port", $user, $password, \%params);

 176:  $dbh->do("SET NAMES 'utf8'") if($dbh && $ENV{'OCS_OPT_UNICODE_SUPPORT'});

177:  $dbh->do("SET sql_mode='NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION'");

 I'm really lost right now :/ I've already installed OCS on a Debian like... 2 weeks ago for testing, it perfectly worked... And now it don't :/

Thanks for you help mate !! ;)

-------------------------------------------------Francais-------------------------------------------------

Salut tout le monde !

J'ai installé OCS Server sur une nouvelle machine virtuel. L'installation c'est bien passé, mais je ne peu pas recevoir les données des Clients.

Dans le log du Client je trouve ca :

[/NOW] used, so launching "C:\Program Files (x86)\OCS Inventory Agent\ocsinventory.exe"...Result: 4

J'ai verifié deux fois, l'adresse ip du serveur est la bonne

Du coup j'ai regardé dans error.log et j'ai trouvé ca (bon ca veux au moins dire que y'a contacte entre les deux machine :

[Wed Jun 01 09:45:11.527135 2016] [perl:error] [pid 17035] [client 192.168.225.100:51879] Can't call method "do" on an undefined value at /usr/local/share/perl/5.20.2/Apache/Ocsinventory/Server/System.pm line 177.\n

Dans le fichier indiqué on trouve ca (rien de spécial quoi) :

175:  my $dbh = DBI->connect("DBI:mysql:database=$database;host=$host;port=$port", $user, $password, \%params);

 176:  $dbh->do("SET NAMES 'utf8'") if($dbh && $ENV{'OCS_OPT_UNICODE_SUPPORT'});

177:  $dbh->do("SET sql_mode='NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION'");

Donc je suis un peu perdu la :/ j'ai déjà installé OCS sur un Debian il y a genre... 2 semaines pour tester, ca avait marché sans soucis. Et maintenant ca marche plus :(

Merci de votre aide ! :)

in OCS Inventory NG server for Unix by (1k points)
edited by

1 Answer

0 votes
by (20.5k points)
Ohhhhhhhhhhhh god i love you :D
Je vais testé ca mais en effet... Ca ressemble bien à un truc dans le genre ! Merci ;)

Edit : Cela fonctionne. J'avais fait une faute de frappe en tappant le mot de passe dans z-ocs... Merci !! :D
 
Powered by Question2Answer
...