Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.4 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Problem with plugins

Hi, I'm trying to install the plugin (winusers, uptime, officepack) after updating the ocs-server, version 2.1 to 2.2. After i click install the first time just get a blank screen, updating, if you try to install again get the message " This plugin has been already installed ", but no plugin appears as installed.

Sorry for the bad english.

asked Jun 7, 2016 in OCS Inventory NG server for Unix by zoom (210 points)

7 Answers

+1 vote
Hi,

can you send your error log from apache after installing a plugin ?

Are you upgrading from a older version of ocs ?

Regards,

Gilles Dubois.
answered Jun 9, 2016 by gillesdubois (2,850 points)

Hi, thanks for reply!

I was using version 2.1 the server before upgrading to 2.2. They were installed plugins winuser and uptime.

Error log opening plugin-manager page:

[Thu Jun 09 08:16:34 2016] [error] [client 10.8.220.157] File does not exist: /srv/www/htdocs/usr, referer: http://10.8.208.33/ocsreports/?function=pluginsmanager
[Thu Jun 09 08:16:34 2016] [error] [client 10.8.220.157] File does not exist: /srv/www/htdocs/usr, referer: http://10.8.208.33/ocsreports/?function=pluginsmanager
[Thu Jun 09 08:16:34 2016] [error] [client 10.8.220.157] File does not exist: /srv/www/htdocs/usr, referer: http://10.8.208.33/ocsreports/?function=pluginsmanager
[Thu Jun 09 08:16:34 2016] [error] [client 10.8.220.157] File does not exist: /srv/www/htdocs/usr, referer: http://10.8.208.33/ocsreports/?function=pluginsmanager
[Thu Jun 09 08:16:34 2016] [error] [client 10.8.220.157] File does not exist: /srv/www/htdocs/usr, referer: http://10.8.208.33/ocsreports/?function=pluginsmanager
[Thu Jun 09 08:16:34 2016] [error] [client 10.8.220.157] File does not exist: /srv/www/htdocs/usr, referer: http://10.8.208.33/ocsreports/?function=pluginsmanager
[Thu Jun 09 08:16:34 2016] [error] [client 10.8.220.157] File does not exist: /srv/www/htdocs/usr, referer: http://10.8.208.33/ocsreports/?function=pluginsmanager

No error in log after click in install, just a blank screen on browser.
In debug mode:

One more time, sorry for the bad english and thanks for help.

0 votes
Hi, if someone can help me, please.

Thanks.
answered Jun 15, 2016 by zoom (210 points)
+1 vote
Hi,

Errors in apache error.log file?

Regards

Frank
answered Jun 16, 2016 by frankb (52,090 points)

Hi, thanks for reply!

I was using version 2.1 the server before upgrading to 2.2. They were installed plugins winuser and uptime.

Error log opening plugin-manager page:

[Thu Jun 09 08:16:34 2016] [error] [client 10.8.220.157] File does not exist: /srv/www/htdocs/usr, referer: http://10.8.208.33/ocsreports/?function=pluginsmanager
[Thu Jun 09 08:16:34 2016] [error] [client 10.8.220.157] File does not exist: /srv/www/htdocs/usr, referer: http://10.8.208.33/ocsreports/?function=pluginsmanager
[Thu Jun 09 08:16:34 2016] [error] [client 10.8.220.157] File does not exist: /srv/www/htdocs/usr, referer: http://10.8.208.33/ocsreports/?function=pluginsmanager
[Thu Jun 09 08:16:34 2016] [error] [client 10.8.220.157] File does not exist: /srv/www/htdocs/usr, referer: http://10.8.208.33/ocsreports/?function=pluginsmanager
[Thu Jun 09 08:16:34 2016] [error] [client 10.8.220.157] File does not exist: /srv/www/htdocs/usr, referer: http://10.8.208.33/ocsreports/?function=pluginsmanager
[Thu Jun 09 08:16:34 2016] [error] [client 10.8.220.157] File does not exist: /srv/www/htdocs/usr, referer: http://10.8.208.33/ocsreports/?function=pluginsmanager
[Thu Jun 09 08:16:34 2016] [error] [client 10.8.220.157] File does not exist: /srv/www/htdocs/usr, referer: http://10.8.208.33/ocsreports/?function=pluginsmanager

No error in log after click in install, just a blank screen on browser.
In debug mode:

One more time, sorry for the bad english and thanks for help.

Was there a solution for this problem?? I'm exactly with the same problem :-(
+1 vote
Did you solve your problem? I'm suffering from the same pain :-(
answered Jul 19, 2016 by hserras (280 points)
No, the problem persists .... and found nothing related in the Internet.
0 votes
Create a backup of everything. Then, clear all traces of these plugins that you had installed before the upgrade (the cd_files, entries in database (and Map.pm), etc). So, try to reinstall by the Plugin interface. I had to do that when i tried to install the officekey plugin.

Again: Create a backup of all related files and database.
answered Jul 20, 2016 by carvanders (210 points)
I try, but still the same problem. I cleal all traces of uptime plugin, after this, after click in install again, just a blank screen on browse and the db table wont created. this files are created:

./ocsreports/plugins/main_sections/ms_uptime
./ocsreports/plugins/main_sections/ms_uptime/uptime
./ocsreports/plugins/main_sections/ms_uptime/uptime/agent/Unix/uptime.pm
./ocsreports/plugins/main_sections/ms_uptime/uptime/agent/Windows/uptime.vbs
./ocsreports/plugins/main_sections/ms_uptime/uptime/cd_uptime
./ocsreports/plugins/main_sections/ms_uptime/uptime/cd_uptime/cd_uptime.php
./ocsreports/plugins/main_sections/ms_uptime/uptime/APACHE/uptime.conf

Sorry for the english.
0 votes

Any suggestions? i am getting the same error on 2.3.1:

  • OS Name :
  • Version :
  • RAM installed :
  • Free RAM :
  • CPU :
  • Distribution :
  • Linux x86_64
  • 2.6.32-642.el6.x86_64
  • 1829 MB
  • Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz
  • CentOS release 6.9 (Final)

/var/log/httpd/error_log:

[Thu Apr 20 17:43:54 2017] [error] [client 79.191.217.59] PHP Fatal error:  Uncaught PDOException: SQLSTATE[HY000] [2002] No such file or directory in /usr/share/ocsinventory-reports/ocsreports/plugins/main_sections/ms_plugins/functions_check.php:49\nStack trace:\n#0 /usr/share/ocsinventory-reports/ocsreports/plugins/main_sections/ms_plugins/functions_check.php(49): PDO->__construct('mysql:host=;dbn...', 'root', 'root')\n#1 /usr/share/ocsinventory-reports/ocsreports/plugins/main_sections/ms_plugins/ms_pluginsmanager.php(124): check(Array)\n#2 /usr/share/ocsinventory-reports/ocsreports/require/header.php(437): require('/usr/share/ocsi...')\n#3 /usr/share/ocsinventory-reports/ocsreports/index.php(44): require('/usr/share/ocsi...')\n#4 {main}\n  thrown in /usr/share/ocsinventory-reports/ocsreports/plugins/main_sections/ms_plugins/functions_check.php on line 49, referer: http://starsq.ddns.net:4433/ocsreports/index.php?function=pluginsmanager

answered Apr 20 by Mody (200 points)
0 votes
Try to change the permissions to plugin package and the download folder:

chmod www-data:www-data YourPlugin.zip

cd ..

chmod 777 -R download
answered May 12 by ciaoidea (320 points)
 
Powered by Question2Answer
...