Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.4 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Pas d'inventaire des agents OCS

Bonjour à tous,

Je déploie actuellement une solution OCS/GLPI sur un server Debian Jessie  sur un parc fonctionnant sur de l'OS Windows (Principalement XP et 7), et je rencontre un problème après le déploiement des agents OCS.

Je vous explique : l'installation du server OCS:GLPI s'est déroulée sans encombres, les interfaces web sont bien accessibles et les accès aux bases de données (Mysql) sont opérationnels. J'ai installer la version 2.0.5 d'OCS server, et je déploie des agents en version 2.1.1.3.

Je fais le déploiement avec l'outil OCS Deploy Tool, télécharger depuis le site officiel, l'installation sur les clients est OK mais une fois ceux ci installés, mon serveur voit bien qu'un l'agent l'a contacté, il créer une entrée d'inventaire, mais ne remonte que la version de l'agent du poste qui l'a contacté ...(Je pourrais fournir une capture d'écran si mon explication n'est pas claire).

Avec wireshark et les logs du server apache, j'ai vu qu'une erreur 500 se produisait à chaque fois que l'agent envoyait ses données, mais je n'ai pas réussi à en savoir plus ...

Désolé d'avance du peu d'informations données dans ce sujet, j'en donnerais au cas par cas suivant les solutions que vous pourriez me proposer ... Je vous avoues que c'est la première fois que je met en place cette solution sur un parc, je sors tout juste de l'école :(

D'avance merci pour m'avoir lu et de votre aide !
asked Jun 15, 2016 in OCS Inventory NG server for Unix by Bobber (200 points)

2 Answers

0 votes
Bonjour

Il faut OCS server 2.1 ou 2.2 avec des agents 2.1.1.3 sinon cela ne fonctionne pas.

Cordialement

Frank
answered Jun 15, 2016 by frankb (53,050 points)
Merci de la réponse rapide !

J'en viens donc a mon second problème, la mise à jour d'OCS server, j'ai bien essayer en récupérant le paquet depuis le site, mais après avoir executer le script setup.sh et redémarrer mon service Apache, la mise à niveau n'est pas faite ... Je dois rater un paramètre dans le script, savez vous où je pourrais consulter une documentation détaillées à ce sujet ? ...

Cordialement,
0 votes
Bonjour,

Déjà il faudrait regarder dans le fichier de log d'installation s'il y a des erreurs. Lorsque tu fais la mise à jour il faut d'abord sauvegarder les fichiers de conf existants car ils seront écrasés après la mise à jour.

Y-a-t-il des erreurs dans le fichier ocsinventory.log de l'agent, error.log d'apache?

Cordialement

Frank
answered Jun 16, 2016 by frankb (53,050 points)
Bonjour,

la seule erreur présente dans le error.log d'apache est :

____________________________________________________________________

[Thu Jun 16 10:31:12.641405 2016] [:error] [pid 4694] [client 172.30.64.255:51226] PHP Deprecated:  mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /usr/share/ocsinventory-reports/backend/require/connexion.php on line 10, referer: http://172.30.64.133/ocsreports/index.php

____________________________________________________________________

Et côté Agent le fichier de log ne me dis que :

================= TRACE STOP ===============
ERROR *** AGENT => Failed to send Inventory <HTTP Status Code #500>

__________________________________________________________________

Ces erreurs peuvent elles être bloquantes pour la montée en version en OCSServer 2.2 ?

Concernant les fichiers de configuration, j'ai sauvegarder les fichiers ocsinventory-server.conf et ocsinventory-reports.conf, y a t'il autre chose à conserver avant de lancer la mise à jour ?

Cordialement,
 
Powered by Question2Answer
...