Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.8 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Agent (windows & Linux) dont send information to server ocs

Hello All,

I have installed OCS on Linux (Cent os 7) and can see and login to UI.

after that I have installed agent on windows also Linux on multiple system but its not connecting to server.

On windows, it shows started but dont see any error.

Has anyone any idea??

Regards,
in OCS Inventory NG agent for Windows by (120 points)

2 Answers

0 votes
Hi,

Open ocsinventory.log file and see if you have some errors.

Which url have you setup in ocsinventory.ini file?

Be sure that mod_perl is installed, configured and activated on your ocs server.

Regards

Frank
by (79.6k points)
Hello Frank,

Please find the answers inline

Open ocsinventory.log file and see if you have some errors.
    - NO errors found

Which url have you setup in ocsinventory.ini file?
    - 192.168.x.x:80/ocsinventory

  - Also tried 192.168.x.x/ocsinventory

Be sure that mod_perl is installed, configured and activated on your ocs server.
    - mod_perl already installed, OCS server configured and activated.

Thanks,
Sachin
0 votes

The same issue on Windows 10 agent 2.1.1.3 Server available on http://192.168.0.17

==============================================================================
Starting OCS Inventory NG Agent on Tuesday, September 27, 2016 22:33:19.
AGENT => Running OCS Inventory NG Agent Version 2.1.1.3
AGENT => Using OCS Inventory NG FrameWork Version 2.1.1.3
AGENT => Loading plug-in(s)
    DLL PLUGIN => Searching for Plug-in DLL(s) in folder <C:\Program Files (x86)\OCS Inventory Agent\plugins>
    DLL PLUGIN => 0 DLL Plug-in(s) successfully loaded on 0 DLL(s) found
AGENT => Using network connection with Communication Server
    COM PROVIDER => Loading Communication Provider <C:\Program Files (x86)\OCS Inventory Agent\ComHTTP.dll>
AGENT => Using Communication Provider <OCS Inventory NG cURL Communication Provider> Version <2.1.1.3>
    AGENT => Sending getLabel request
    COM SERVER => Initializing cURL library for getFile
    COM SERVER => Using cURL without server authentication
    COM SERVER => Disabling cURL proxy support
    COM SERVER => Disabling cURL SSL server validation support
    COM SERVER => Sending fileGet request to URL <http://192.168.0.17/deploy/label>
    COM SERVER => fileGet response received <HTTP Status Code #404>
    COM SERVER => Cleaning cURL library
    AGENT => Failed to retrieve Label <HTTP Status Code #404>
AGENT => Sending Prolog
    DID_CHECK => Read DeviceID <DN-1-2016-09-27-21-49-04> and MACs <E0:2A:82:FE:B4:C42C:76:8A:E5:43:60> in file <ocsinventory.dat>
    COM SERVER => Initializing cURL library for sendRequest
    COM SERVER => Using cURL without server authentication
    COM SERVER => Disabling cURL proxy support
    COM SERVER => Disabling cURL SSL server validation support
    COM SERVER => Sending HTTP Post request to URL <http://192.168.0.17>
    COM SERVER => HTTP Post response received <HTTP Status Code #200>
    COM SERVER => Cleaning cURL library
AGENT => Prolog successfully sent
SUPPORT => No support detected, Registration key : N/A
    AGENT => Prolog Frequency set to 10 hour(s)
AGENT => Unloading communication provider
AGENT => Unloading plug-in(s)
AGENT => Execution duration: 00:00:00.

by (180 points)
Hello All,

Please help me for the same.

Thanks,

Sachin Wagde
 
Powered by Question2Answer
...