Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.6 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Agent does not report to the server computers.

I have the server installed on a CentOS IP 192.168.2.19, I access it by http://192.168.2.19:81/ocsreports

I use port 81 because I have external NAT and another application on port 80

I installed the agent on Windows computers but when running the computer is not added on the server.

Could you help me? I may have missed some configuration on the server...I do no..

Below .ini and .log

OCS INVENTORY.INI 

[OCS Inventory Agent]
ComProvider=ComHTTP.dll
Debug=0
Local=
NoSoftware=0
HKCU=0
NoTAG=0
IpDisc=
[HTTP]
Server=http://192.168.2.19:81/ocsreports
SSL=0
CaBundle=cacert.pem
AuthRequired=0
User=
Pwd=
ProxyType=0
Proxy=
ProxyPort=0
ProxyAuthRequired=0
ProxyUser=
ProxyPwd=
[OCS Inventory Service]
PROLOG_FREQ=10
OLD_PROLOG_FREQ=10
TTO_WAIT=35760

OCS INVENTORY.LOG

==============================================================================
Starting OCS Inventory NG Agent on Wednesday, October 26, 2016 19:16:57.
AGENT => Running OCS Inventory NG Agent Version 2.1.1.3
AGENT => Using OCS Inventory NG FrameWork Version 2.1.1.3
AGENT => Loading plug-in(s)
AGENT => Using network connection with Communication Server
AGENT => Using Communication Provider <OCS Inventory NG cURL Communication Provider> Version <2.1.1.3>
AGENT => Sending Prolog
AGENT => Prolog successfully sent
SUPPORT => No support detected, Registration key : N/A
AGENT => Unloading communication provider
AGENT => Unloading plug-in(s)
AGENT => Execution duration: 00:00:00.

in OCS Inventory NG agent for Windows by (160 points)

4 Answers

0 votes
You are not sending the inventory to the server.

The URL for the server will be Server=http://192.168.2.19:81/ocsinventory
by (21k points)
0 votes

Hi Kapouik, thanks for awsner.

So.. I changed as you indicated, follow the .ini

[OCS Inventory Agent]
ComProvider=ComHTTP.dll
Debug=0
Local=
NoSoftware=0
HKCU=0
NoTAG=0
IpDisc=
[HTTP]
Server=http://192.168.2.19:81/ocsinventory
SSL=0
CaBundle=cacert.pem
AuthRequired=0
User=
Pwd=
ProxyType=0
Proxy=
ProxyPort=0
ProxyAuthRequired=0
ProxyUser=
ProxyPwd=
[OCS Inventory Service]
PROLOG_FREQ=10
OLD_PROLOG_FREQ=10
TTO_WAIT=0

Below the error in the log: 

 ==============================================================================
Starting OCS Inventory NG Agent on Thursday, October 27, 2016 11:21:24.
AGENT => Running OCS Inventory NG Agent Version 2.1.1.3
AGENT => Using OCS Inventory NG FrameWork Version 2.1.1.3
AGENT => Loading plug-in(s)
AGENT => Using network connection with Communication Server
AGENT => Using Communication Provider <OCS Inventory NG cURL Communication Provider> Version <2.1.1.3>
AGENT => Sending Prolog
ERROR *** AGENT => Failed to send Prolog <HTTP Status Code #404>
AGENT => Unloading communication provider
AGENT => Unloading plug-in(s)
AGENT => Execution duration: 00:00:00.

In the browser this URL does not access, it should access? May I have missed something in my setup 

by (160 points)
0 votes

Hi,

Your OCS server is installed on which OS? linux, windows?

Error 404 means: 

  1. url ocsinventory not available => module mod_perl not installed and not activated on apache 
  2. a firewall is started on the server or on the client and port 81 is not open
Regards
Frank
by (70.3k points)
0 votes

Configure following Symbolic Links and Configuration

Step1:

vi /etc/apache2/conf-available/ocsinventory-reports.conf 

add Alias as below:

Alias /ocsreports  /usr/share/ocsinventory-reports/ocsreports

cd /etc/apache2/sites-enable

ln -s ../conf-available/z-ocsinventory-server.conf  ocsinventory.conf

ln -s ../conf-available/ocsinventory-reports.conf ocsreports.conf

service apache2 restart

by (260 points)
 
Powered by Question2Answer
...