Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.5 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

From debian to latest version

Hello,

I am currently using OCS inventory server and agent from debian repository. So I used an old version 2.0.5.

This cause me trouble because :

- on RHEL or Centos I have an up to date client which doesn't work with my old server,

- Ocs inventory plugin for glpi doesn't work well with this old server.

The thing is I don't know how to migrate to the new version, as using debian package is very easy to deploy on lot of servers (I use puppet for this).

Upgrading seems very hard as I didn't found any debian package for the lastest release (especially for the agent).

Any idea on  how to proceed ?
asked in OCS Inventory NG server for Unix by (120 points)

1 Answer

0 votes
Just reinstall the server,  write your own manifest for do the installation from sources, i'm not sure if you're able to use the existent database, but anyway if you preserve the ip/hostname for the new instalation the agents will should be able to report normally in the new versiĆ³n.

Please let me know if you solve the problem in any way.
answered by (1.7k points)
 
Powered by Question2Answer
...