Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.5 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Exit_code_32 in Windows 10 Agent

Hi,

Im trying to deploy a .bat which contains a .exe installation with OCS (for example winrar.exe). This .bat file basically copy my ".exe" file from a shared folder in the remote PC & then execute it with runas /user:domain\administrador command.

I'd tryed this with action->execute & action->launch .bat but anyway it failed. I get the exit_code_32 on my w10 agent...
Here the logs:

File -> ocsinventory.log

==============================================================================

Starting OCS Inventory NG Agent on Sunday, December 18, 2016 19:45:31.
AGENT => Running OCS Inventory NG Agent Version 2.1.1.3
AGENT => Using OCS Inventory NG FrameWork Version 2.1.1.3
AGENT => Loading plug-in(s)
AGENT => Using network connection with Communication Server
AGENT => Using Communication Provider <OCS Inventory NG cURL Communication Provider> Version <2.1.1.3>
AGENT => Sending Prolog
AGENT => Prolog successfully sent
SUPPORT => No support detected, Registration key : N/A
AGENT => Inventory required
AGENT => Launching hardware and software checks
AGENT => Communication Server ask for IpDiscover
AGENT => Sending Inventory
INVENTORY => Inventory changed since last run
AGENT => Inventory successfully sent
AGENT =>  Communication Server ask for Package Download
DOWNLOAD => Package <1482084428> added to download queue
DOWNLOAD => Download and setup tool successfully started
AGENT => Unloading communication provider
AGENT => Unloading plug-in(s)
AGENT => Execution duration: 00:00:40.

File -> download.log

==============================================================================
Starting OCS Inventory NG Package Download and Setup Tool on Sunday, December 18, 2016 19:46:11.
DOWNLOAD => Running OCS Inventory NG Download Version 2.1.1.3
DOWNLOAD => Using OCS Inventory NG FrameWork Version 2.1.1.3
DOWNLOAD => Using network connection with Communication Server
DOWNLOAD => Using Communication Provider <OCS Inventory NG cURL Communication Provider> Version <2.1.1.3>
DOWNLOAD => Starting new period of 10 cycles
DOWNLOAD => Parsing directory <C:\ProgramData\OCS Inventory NG\Agent\download> for packages
DOWNLOAD => Package <1482084428> verified and added to process queue
DOWNLOAD => Downloading package fragment <1482084428-1>
DOWNLOAD => Building package <1482084428>
DOWNLOAD => Executing action <LAUNCH> for package <1482084428>
ERROR *** DOWNLOAD => Will not register package <1482084428> in history: result <EXIT_CODE_32> not a success
DOWNLOAD => Sending result code <EXIT_CODE_32> for package <1482084428>
DOWNLOAD => Starting new period of 10 cycles
DOWNLOAD => Parsing directory <C:\ProgramData\OCS Inventory NG\Agent\download> for packages
DOWNLOAD => No package found, exiting
DOWNLOAD => Unloading communication provider
DOWNLOAD => Execution duration: 00:10:27.

Please any ideas? Someone could help me?

Thanks & Regards.

Edit: I've SSL enabled on my server & i can see the download page like here:

https_enabled

asked in OCS Inventory NG agent for Windows by (290 points)

7 Answers

0 votes
Hi,

Verfiy that you have many download.exe processes. If true then kill them and restart a inventory with download. If problem persists then open a bug here => https://github.com/OCSInventory-NG/WindowsAgent/issues/new

Regards

Frank
answered by (63.8k points)
0 votes
Hi Frank,

If you literally refer to the "download.exe" processes I don't see any of these. Or do you mean any ".exe" process?

Anyway i've opened a new post in that link. Thanks

Regards.
answered by (290 points)
0 votes
Well something was wrong with my agent's certificate so i generated a new server certificate & copy ".pem" file on my agent's folder. Then i can see the "download.exe process" that u mean but the download dont finish.

DOWNLOAD => Executing action <LAUNCH> for package <1482084428>

Maybe my .bat file is wrong?

Regards.
answered by (290 points)
0 votes
Hi,

What command launches your .bat?

Regards

Frank
answered by (63.8k points)
0 votes

File -> winrar.bat

xcopy \\192.168.1.200\Software$\winrar C:\Software\winrar /S /Y /I

cd C:\Software\winrar

winrar.exe /s

rd /S /Q C:\Software\winrar

answered by (290 points)
0 votes

Finally i can deploy & install software with ocs deployment.

file -> ocsinventory.ini

[OCS Inventory Agent]
ComProvider=ComHTTP.dll
Debug=0
Local=
NoSoftware=0
HKCU=0
NoTAG=0
IpDisc=
[HTTP]
Server=http://192.168.1.132/ocsinventory
SSL=0
CaBundle=cacert.pem
AuthRequired=0
User=
Pwd=
ProxyType=0
Proxy=
ProxyPort=0
ProxyAuthRequired=0
ProxyUser=
ProxyPwd=
[OCS Inventory Service]
PROLOG_FREQ=1
OLD_PROLOG_FREQ=1
TTO_WAIT=0

I've also the cacert.pem on my folder & i follow this steps:  http://ask.ocsinventory-ng.org/4643/deploying-software-with-ocs-for-windows?show=4643#q4643

answered by (290 points)
0 votes

Hi fleisis, sorry for the question in a question, but i just came across this during my hunt for an answer.

In regards to your configuration output below:

PROLOG_FREQ=1
OLD_PROLOG_FREQ=1
TTO_WAIT=0

How were you able to get these parameters? I am trying to get an inventory every hour like this, but cannot figure out how. Here is a link to the question i just posted with more info, I'd love to know how you did it. Thanks!

http://ask.ocsinventory-ng.org/5591/using-ocspackager-how-alter-inventory-frequency-every-hour




Finally i can deploy & install software with ocs deployment.

file -> ocsinventory.ini

[OCS Inventory Agent]
ComProvider=ComHTTP.dll
Debug=0
Local=
NoSoftware=0
HKCU=0
NoTAG=0
IpDisc=
[HTTP]
Server=http://192.168.1.132/ocsinventory
SSL=0
CaBundle=cacert.pem
AuthRequired=0
User=
Pwd=
ProxyType=0
Proxy=
ProxyPort=0
ProxyAuthRequired=0
ProxyUser=
ProxyPwd=
[OCS Inventory Service]
PROLOG_FREQ=1
OLD_PROLOG_FREQ=1
TTO_WAIT=0

answered by (160 points)
 
Powered by Question2Answer
...