Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.5 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

[error] Cannot establish communication : 500 Internal Server Error

Hi

Since a week we got a HTTP 500 error when the OCS Agent send the data to the OCS Server on Suse !
On the server and on the agent was nothing changed ! The error occured the first time at 03:00.
Also in the logfiles I can't find a "real" error. mysql is running. System was booted without success.
Yesterday I stopped and started the mysql DB, and magic 2 agents could store there data in the DB (seen in the OCS GUI). This behavior could not be reproduced now. Stop and start of the mysql DB didn't help anymore.

OCS Server is 2.0.4, MySQL is  5.5.49, both running on Suse Enterprise 11, SP4
Here are entry from the logfiles:

/var/log/ocsinventory-server/activity.log
------------------------------------------------------
Wed Dec 21 07:30:39 2016;4924;100;SVR-OFTRINGNF11-2012-09-05-13-43-19;172.22.233.218;COOP_customized_windows_agent_v2.0.4.1;prolog;accepted
Wed Dec 21 07:30:39 2016;4924;311;SVR-OFTRINGNF11-2012-09-05-13-43-19;172.22.233.218;COOP_customized_windows_agent_v2.0.4.1;session;started
Wed Dec 21 07:31:05 2016;6533;319;SVR-OFTRINGNF11-2012-09-05-13-43-19;172.22.233.218;COOP_customized_windows_agent_v2.0.4.1;session;found
Wed Dec 21 07:31:05 2016;6533;104;SVR-OFTRINGNF11-2012-09-05-13-43-19;172.22.233.218;COOP_customized_windows_agent_v2.0.4.1;inventory;incoming
Wed Dec 21 07:31:05 2016;6533;515;SVR-OFTRINGNF11-2012-09-05-13-43-19;172.22.233.218;COOP_customized_windows_agent_v2.0.4.1;end;error

/var/log/apache2/access_log
------------------------------------------
172.20.214.218 - - [21/Dec/2016:07:32:13 +0100] "POST /ocsinventory HTTP/1.1" 200 302 "-" "COOP_customized_windows_agent_v2.0.4.1"
172.30.199.218 - - [21/Dec/2016:07:32:13 +0100] "POST /ocsinventory HTTP/1.1" 200 302 "-" "COOP_customized_windows_agent_v2.0.4.1"
172.20.214.218 - - [21/Dec/2016:07:32:30 +0100] "POST /ocsinventory HTTP/1.1" 500 1058 "-" "COOP_customized_windows_agent_v2.0.4.1"
172.30.199.218 - - [21/Dec/2016:07:32:37 +0100] "POST /ocsinventory HTTP/1.1" 500 1058 "-" "COOP_customized_windows_agent_v2.0.4.1"


Any ideas, tipps, tricks ???
ANY help is very welcome !!!

Is there a possibility to set a debug loglevel to see more informations ?

Thank you very much !!!
Regards,
Frank

asked in OCS Inventory NG server for Unix by (160 points)

2 Answers

0 votes
Hi,

Please post content of /var/log/apache2/erro_log file.

Regards

Frank
answered by (69.9k points)
0 votes
Frank

I can't see any error in the less /var/log/apache2/error_log

In the meantime I deleted all the data in the ocsweb DB as a test - after a restart all the data was re-sended from the OCS agent.
So I guess the problem must be anywhere in the mysql DB.

Regards, Franky
answered by (160 points)
 
Powered by Question2Answer
...