Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.5 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Deployment Activate

Hi

When I activate a deploy generates the following message:

WARNING: Can't find information file at https://XXX.XXX.XXX.XXX/download/1485285396/

Are you sure to want to activate this package?

Can someone help me ?
 

asked in OCS Inventory NG server for Unix by (380 points)

5 Answers

0 votes
Hi,

Verify that you can access the url from your browser.

Regards

Frank
answered by (63.8k points)
0 votes

Hi Frank,

Follow the lab logs that I'm doing the tests, 

http://20.20.20.56/download/

Forbidden

You don't have permission to access /download/ on this server.


Apache/2.4.10 (Debian) Server at 20.20.20.56 Port 80

LOG apache:

[Thu Jan 26 12:43:56.026884 2017] [autoindex:error] [pid 761] [client 20.20.20.1:37736] AH01276: Cannot serve directory /var/lib/ocsinventory-reports/download/: No matching DirectoryIndex (index.html,index.cgi,index.pl,index.php,index.xhtml,index.htm) found, and server-generated directory index forbidden by Options directive

Directory content download:

drwxrwxr-x 3 root     www-data 4.0K Jan 24 16:47 ..
-rw-r--r-- 1 www-data www-data 1.1M Jan 24 16:47 1485283597-1
-rw-r--r-- 1 www-data www-data  370 Jan 24 16:47 info

Directory permission download

drwxrwxr-x  3 root www-data 4.0K Jan 24 16:47 download

Content file info:

http://20.20.20.56/download/1485283597/info

<DOWNLOAD ID="1485283597" PRI="5" ACT="EXECUTE" DIGEST="d9105d2b725c696e116304e6c15251e0" PROTO="HTTP" FRAGS="1" DIGEST_ALGO="MD5" DIGEST_ENCODE="Hexa"COMMAND="7z1604.exe" NOTIFY_USER="0" NOTIFY_TEXT="" NOTIFY_COUNTDOWN="" NOTIFY_CAN_ABORT="0" NOTIFY_CAN_DELAY="0" NEED_DONE_ACTION="0" NEED_DONE_ACTION_TEXT=""GARDEFOU="rien"/>

answered by (380 points)
0 votes
Hi,

Edit ocsinventory-reports.conf file and set same permissions for /download section as /ocsreports section. Save and restart apache.

Regards

Frank
answered by (63.8k points)
0 votes

Hi, 

I tested with version 2.3 and 2.1.2, and it presents the following error when I activate a package in the deployment:

WARNING: Can't find information file at https://localhost/download/1485541349/
WARNING: Can't find fragments files at http://localhost/download/1485541349/

Are you sure to want to activate this package?

I tested with ssl and without ssl,

Can you help me?

answered by (380 points)
0 votes
Hi!

I was stuck with that exact nightmare 2 days.

You have to add the following code lines to your Apache config file (/etc/httpd/conf/httpd.conf)

#Estas lineas posibilitan el acceso a http://192.168.104.5/download/

Alias /download "/var/lib/ocsinventory-reports/download"

<Directory "/var/lib/ocsinventory-reports/download">

Options Indexes FollowSymLinks MultiViews

AllowOverride None

Require all granted

</Directory>

You need also to verify permissions mask in the download path with:

chmod 775 /var/lib/ocsinventory-reports/download
answered by (140 points)
 
Powered by Question2Answer
...