Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.5 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Crash after 2.3 update

Hello,

I've tried to update OCS to 2.3 from 2.1.2.

Install works fine but now there is nothing else on ocs than the menu on the top of the screen....please help !!!

http://hpics.li/34161b6
asked in OCS Inventory NG server for Unix by (360 points)

8 Answers

0 votes
Confirmed on my server is the same - in error_log nothing interesing
answered by (140 points)
0 votes
Any idea to solve this problem ???
answered by (360 points)
0 votes
Hi,

Which errors have you in apache error.log or error_log file? I think that a php package is missing and particulary php-curl, perhaps php-xml. So install them and retry.

Regards

Frank
answered by (67k points)
0 votes

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet php-xml

Voilà ce qu'il se passe lorsque j'essai d'installer php-xml meme chose pour php-curl

Je ne trouve rien en rapport avec OCS dans mon error.log

Voici ce que je peux voir durant l'installation...

Checking for DBI PERL module...
Found that PERL module DBI is available.
Checking for Apache::DBI PERL module...
Found that PERL module Apache::DBI is available.
Checking for DBD::mysql PERL module...
Found that PERL module DBD::mysql is available.
Checking for Compress::Zlib PERL module...
Found that PERL module Compress::Zlib is available.
Checking for XML::Simple PERL module...
Found that PERL module XML::Simple is available.
Checking for Net::IP PERL module...
Found that PERL module Net::IP is available.
Checking for SOAP::Lite Perl module...
Found that PERL module SOAP::Lite is available.
Checking for Archive::Zip Perl module...
*** ERROR: PERL module Archive::Zip is not installed !
*** ERROR: There is one or more required PERL modules missing on your computer !
Please, install missing PERL modules first.

OCS setup.sh can install perl module from packages for you
The script will use the native package from your operating system like apt or rpm
Do you wish to continue (y/[n])?

answered by (360 points)
edited by
0 votes
Any idea ?? please
answered by (360 points)
0 votes
Hi,

Did you find a solution?

I'm facing the same issue and I've no solution yet.

Thank you
answered by (340 points)
0 votes
Yes ! it works now ! I've just update php on my debian Wheezy.
answered by (360 points)
0 votes

I Run PHP 5.6.30-5+deb.sury.org~precise+2 on Ubuntu 12.04 but when i go to http://ocsinventory-ng/ocsreports/install.php I get the following message

Your PHP installation is older than version 5.4 and will not be compatible with incoming versions (version :  5.3.10-1ubuntu3.26 )

It's like my PHP version is not correctly detected by OCS

Thank you in advance

answered by (340 points)
 
Powered by Question2Answer
...