Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.5 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Failed to send Inventory <HTTP Status Code #500 ONLY FOR SOME AGENTS [closed]

Hello,

some windows-agents produced an error  "Failed to send Inventory <HTTP Status Code #500" Many other agents works fine. The installation on the machines are exactly the same! rolled out with Software distribution from Kaspersky.

Here is the content of the agents log:

==============================================================================
Starting OCS Inventory NG Agent on Thursday, February 09, 2017 12:13:06.
AGENT => Running OCS Inventory NG Agent Version 2.1.1.3
AGENT => Using OCS Inventory NG FrameWork Version 2.1.1.3
AGENT => Loading plug-in(s)
    DLL PLUGIN => Searching for Plug-in DLL(s) in folder <C:\Program Files (x86)\OCS Inventory Agent\plugins>
    DLL PLUGIN => 0 DLL Plug-in(s) successfully loaded on 0 DLL(s) found
AGENT => Using network connection with Communication Server
    COM PROVIDER => Loading Communication Provider <C:\Program Files (x86)\OCS Inventory Agent\ComHTTP.dll>
AGENT => Using Communication Provider <OCS Inventory NG cURL Communication Provider> Version <2.1.1.3>
AGENT => Sending Prolog
    DID_CHECK => Read DeviceID <WSFREILANB01-2017-02-08-14-26-24> and MACs <88:AE:1D:E8:FB:A2EA:39:DF:C5:C9:72E8:39:DF:C5:C9:7200:FF:F4:83:12:24> in file <ocsinventory.dat>
    COM SERVER => Initializing cURL library for sendRequest
    COM SERVER => Using cURL without server authentication
    COM SERVER => Disabling cURL proxy support
    COM SERVER => Disabling cURL SSL server validation support
    COM SERVER => Sending HTTP Post request to URL <http://192.168.110.26/ocsinventory>
    COM SERVER => HTTP Post response received <HTTP Status Code #200>
    COM SERVER => Cleaning cURL library
AGENT => Prolog successfully sent
SUPPORT => No support detected, Registration key : N/A
    AGENT => Prolog Frequency set to 24 hour(s)
AGENT => Inventory required
AGENT => Launching hardware and software checks
    INVENTORY => Loading Download history
    INVENTORY => Logged on user ID is <Admin>
    INVENTORY => Operating System is <Microsoft Windows 10 Pro 10.0.14393 >, description <>
    INVENTORY => Operating System uses 64 bits memory address width
    INVENTORY => Computer domain or workgroup is <example>
    INVENTORY => User domain is <>
    INVENTORY => System Manufacturer <TOSHIBA>, System Model <Satellite Pro L670>, System S/N <deleted_for_post_here>, Bios Manufacturer <TOSHIBA>, Bios Date <01/20/11>, Bios Version <2.10>, Motherboard Manufacturer <TOSHIBA>, Motherboard Model <NALAA>, Motherboard S/N <123456789AB>
    INVENTORY => 1 processor(s) Intel(R) Core(TM) i3 CPU       M 370  @ 2.40GHz [2 core(s) x86_64] at 2399 MHz
    INVENTORY => OS Memory 1907 MB, OS Swap size 2995 MB
    INVENTORY => 2 memory slot(s) found
    INVENTORY => 3 input device(s) found
    INVENTORY => 2 system port(s) found
    INVENTORY => 1 system slot(s) found
    INVENTORY => 4 system controller(s) found
    INVENTORY => 4 storage peripheral(s) found
    INVENTORY => 2 sound device(s) found
    INVENTORY => 2 modem(s) found
    INVENTORY => 4 network adapter(s) found
    INVENTORY => 10 system printer(s) found
    INVENTORY => 1 video adapter(s) found
    INVENTORY => 1 system monitor(s) found
    INVENTORY => Default IPv4 address is <192.168.189.51>
    INVENTORY => Registered company <Microsoft>, registered owner <Admin>, Product ID <00330-80...>
    INVENTORY => Product key <TY4CG-JD...>
    INVENTORY => 106 software found
    INVENTORY => Computer/VM UUID is <945A9941-50BD-DF11-A121-88AE1DE8FBA2>
    INVENTORY => Computer seems to be Microsoft virtual host
    INVENTORY => System Memory set to 2048 (instead of 1907)
    INVENTORY => Reading last inventory state
    EXECUTABLE PLUGIN => Searching for VBS script(s) in folder <C:\Program Files (x86)\OCS Inventory Agent\plugins>
    EXECUTABLE PLUGIN => Searching for executable(s) in folder <C:\Program Files (x86)\OCS Inventory Agent\plugins>
AGENT => Sending Inventory
    INVENTORY => Checking last inventory state
    INVENTORY => Storage peripherals inventory state changed
    INVENTORY => Logical drives inventory state changed
    INVENTORY => Modems inventory state changed
    INVENTORY => Printers inventory state changed
    INVENTORY => Software inventory state changed
INVENTORY => Inventory changed since last run
    INVENTORY => Generating XML document with Device properties
    INVENTORY => XML Update BIOS
    INVENTORY => XML Update 1 CPU(s)
    INVENTORY => XML Update 2 Memory Slot(s)
    INVENTORY => XML Update 3 Input Device(s)
    INVENTORY => XML Update 2 System Port(s)
    INVENTORY => XML Update 4 System Controller(s)
    INVENTORY => XML Update 1 System Slot(s)
    INVENTORY => XML Update 2 Sound Device(s)
    INVENTORY => XML Update 4 Storage Peripheral(s)
    INVENTORY => XML Update 5 Logical Drive(s)
    INVENTORY => XML Update 2 Modem(s)
    INVENTORY => XML Update 4 Network Adapter(s)
    INVENTORY => XML Update 1 Video Adapter(s)
    INVENTORY => XML Update 1 Monitor(s)
    INVENTORY => XML Update 10 Printer(s)
    INVENTORY => XML Update 107 Software
    INVENTORY => XML Update 0 Registry Value(s)
    INVENTORY => XML Update Administrative Information(s)
    INVENTORY => XML Update common Device properties
    COM SERVER => Initializing cURL library for sendRequest
    COM SERVER => Using cURL without server authentication
    COM SERVER => Disabling cURL proxy support
    COM SERVER => Disabling cURL SSL server validation support
    COM SERVER => Sending HTTP Post request to URL <http://192.168.110.26/ocsinventory>
    COM SERVER => HTTP Post response received <HTTP Status Code #500>
    COM SERVER => Cleaning cURL library
ERROR *** AGENT => Failed to send Inventory <HTTP Status Code #500>
AGENT =>  Communication Server ask for Package Download
    DOWNLOAD => Package history file cleaning not required
    DOWNLOAD => Download disabled by server
AGENT => Unloading communication provider
AGENT => Unloading plug-in(s)
AGENT => Execution duration: 00:00:10
closed with the note: Problem solved
asked in OCS Inventory NG agent for Windows by (220 points)
closed by

3 Answers

0 votes
I had the same issue, new computers didn't show up, but existing one kept updating...

there was a missing feild in the "network" table, you just have to create the MTU field.

here is my solution : http://ask.ocsinventory-ng.org/5995/les-nouveaux-pc-ne-remontent-pas

If that's not the problem, in the z-ocsinventory-server.conf file you can show the logs (line 52, OCS_DBI_PRINT_ERROR set to 1), then you restart apache, and you'll see errors in the apache error.log
answered by (440 points)
0 votes
Helo,

thank you very much! It was exactly the problem, the missing column 'MTU'!

Thank you & greetings from saxonia!
answered by (220 points)
0 votes
Hi,

This bug has been corrected. The 2.3.1 version is in preparation.

Regards

Frank
answered by (69.3k points)
 
Powered by Question2Answer
...