Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.5 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Upgrade to 2.3.1 fails

Hi,

I'm running 2.3 and want to update to version 2.3.1. When I run setup, leaving all items default, I get the following error:

I downloaded the installer from Github: https://github.com/OCSInventory-NG/OCSInventory-Server/releases

........

Found that PERL module Net::IP is available.

+----------------------------------------------------------+
|      Installing files for Administration server...       |
+----------------------------------------------------------+

Creating PHP directory /usr/share/ocsinventory-reports/ocsreports.
Copying PHP files to /usr/share/ocsinventory-reports/ocsreports.
*** ERROR: Unable to copy files in /usr/share/ocsinventory-reports/ocsreports, please look at error in /root/OCSInventory-Server-2.3.1/ocs_server_setup.log and fix !

Here is the content from the error log:

============================================================
Installing Administration server
============================================================
Checking for Administration Server directories...
Using directory /usr/share/ocsinventory-reports for static files
Using /var/lib/ocsinventory-reports as writable/cache directory
Checking for DBI PERL module
PERL module DBI is available
Checking for DBD::mysql PERL module
PERL module DBD::mysql is available
Checking for XML::Simple PERL module
PERL module XML::Simple is available
Checking for Net::IP PERL module
PERL module Net::IP is available
Creating PHP directory /usr/share/ocsinventory-reports/ocsreports
Copying PHP files to /usr/share/ocsinventory-reports/ocsreports
cp: cannot stat 'ocsreports/*': No such file or directory

I cannot understand what is wrong as 'ocsreports/*' does not make sense to any of the questions I've answered. 

Regards,

Danie 

asked in OCS Inventory NG server for Unix by (1.1k points)
edited by

1 Answer

0 votes
You have download the source from the OCS server. As it you don't have the full package and setup.sh will never work. Please download the full package :

https://www.ocsinventory-ng.org/en/#download-en
answered by (19.2k points)
 
Powered by Question2Answer
...