Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.8 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Deployment->Activate: WARNING: Can't find information file at https://[server-fqn]/download/[id]

For testing and documentation I install OCS Inventory NG 2.3.1 on Ubuntu 16.04.2 LTS.
Access with https is enabled, certificate match server fqn. I use a self signed certificate.
Deployment->Build seems to work. I can upload files and they are seen in the folder, I can also access the folder with https://[server-fqn]/download/[id]/

I check apache2 access.log/error.log and activity.log, but there are no errors reported.

Can someone help me to find out, what's wrong in my configuration? I spend already several hours, but without luck.

Here are some screenshots from the error:

I also have a error when I click on the red marked button (perhaps it comes from the same issue?)

in OCS Inventory NG server for Unix by (440 points)

10 Answers

0 votes
Hi,

The fragments are downloaded without ssl. So use http directly.

Regards

Frank
by (79.8k points)
0 votes

Hi Frank,

thank you for your response. But when I access the page without ssl, the same error comes up.

Some more ideas? Could it be a folder ore file right issue?
Let me know If i should attach my documentation draft to this ticket or send it to you.
I hope someone can help me...

woodle

by (440 points)
0 votes

I really hope someone can help me to get the Deployment feature working.

If someone like to reproduce, I publish my documentation draft under
http://www.hoelzle.net/ocs-inventory-ng-unter-ubuntu-16-04-installieren/

by (440 points)
+1 vote
Is there no one who can help me with this problem?

I can't believe that I'm the only one....
by (440 points)
0 votes
I got the same as you i didn't find a solution either yet
by (390 points)
0 votes
Hi gqut,
can we discuss and share our informations?
It seems no dev/sup/exp read this forum and we are still alone.
I thought this product is still in development and have a good community?!
I hope to hear something from you.

woodle
by (440 points)
0 votes
I send you my mail by private messages
by (390 points)
0 votes
At least I found out that this is a cosmetic issue. 

Although this message was shown, teledeploy works! 

Thanks to gqut poiting me to the right way.
by (440 points)
+1 vote

I have same issue for a while, and even if I knew that it was a cosmetic error, I have always found it very annoying. So today I start searching for others that had same problem, and I think that I found a solution that I want to share with you.

I took this question as it seems the last one.

I am using debian 8 and using cacert.org certificates.

Add new certificates:

wget http://www.cacert.org/certs/root.crt -O /usr/local/share/ca-certificates/cacert-root.crt

wget http://www.cacert.org/certs/class3.crt -O /usr/local/share/ca-certificates/cacert-class3.crt

update-ca-certificates

Restart Apache. That should work. It worked for me. If you are not using Debian/CACert.org then this solution does not work for you. Follow other procedures if you have other OS/CA certificate authority.

by (320 points)
0 votes
Check to make sure you have the certificates (Root/Int) installed on your server. If you can access the path from the browser on your workstation, but still get this message then your server probably can't resolve the Int/root certificate path. The server is acting as the guest here.
by (440 points)
 
Powered by Question2Answer
...