Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.3 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Installation Plugin

Bonjour,

Je me tourne vers vous, car j'ai un problème avec l'installation des plugins. Je voudrai installer les plugins Officepack et teamviewer. Je télécharge les paquets correspondants via https://plugins.ocsinventory-ng.org/. Je place les paquets dans /usr/share/ocsinventory-reports/ocsreports/download/ .

Depuis l'interface du serveur, lorsque je selectionne mon paquet et que je clic sur install, j'ai ce message d'erreur : "Le serveur de communication a rencontré l'erreur suivante lors de l'installation :  Err_02".

Mon serveur est en version 2.3.

Distrib : debian jessie 8.7

Version Agent : 2.3.0.0

Voivi les logs d'Apache (fichier error.log ) :

[Wed Apr 05 06:25:06.173205 2017] [mpm_prefork:notice] [pid 929] AH00163: Apache/2.4.10 (Debian) mod_perl/2.0.10 Perl/v5.20.2 configured -- resuming normal operations
[Wed Apr 05 06:25:06.173322 2017] [core:notice] [pid 929] AH00094: Command line: '/usr/sbin/apache2'
[Wed Apr 05 17:31:06.732051 2017] [mpm_prefork:notice] [pid 929] AH00169: caught SIGTERM, shutting down
[Wed Apr 05 17:31:41.384587 2017] [so:warn] [pid 689] AH01574: module perl_module is already loaded, skipping
[Wed Apr 05 17:31:43.794316 2017] [mpm_prefork:notice] [pid 931] AH00163: Apache/2.4.10 (Debian) mod_perl/2.0.10 Perl/v5.20.2 configured -- resuming normal operations
[Wed Apr 05 17:31:43.794414 2017] [core:notice] [pid 931] AH00094: Command line: '/usr/sbin/apache2'
[Wed Apr 05 17:45:22.663466 2017] [mpm_prefork:notice] [pid 931] AH00169: caught SIGTERM, shutting down
[Wed Apr 05 17:45:48.886107 2017] [so:warn] [pid 851] AH01574: module perl_module is already loaded, skipping
[Wed Apr 05 17:45:50.821499 2017] [mpm_prefork:notice] [pid 935] AH00163: Apache/2.4.10 (Debian) mod_perl/2.0.10 Perl/v5.20.2 configured -- resuming normal operations
[Wed Apr 05 17:45:50.821568 2017] [core:notice] [pid 935] AH00094: Command line: '/usr/sbin/apache2'

Dans l'interface graphique, au niveau d'un poste dans l'onglet logiciel, j'ai bien une partie "OFFICE LICENCES" mais sans licences...

Merci d'avance pour votre aide
asked Apr 5 in OCS Inventory NG server for Unix by Xavier (240 points)

1 Answer

+2 votes
 
Best answer

Bonjour,

Tu peux essayer la solution que je donne dans ce thread : https://ask.ocsinventory-ng.org/6024/erreur-lors-linstallation-plugin-officepack-sur-version-en

Le problème vient du fait que le fichier de conf et de map ne sont pas créés automatiquement sur le serveur.
Il te faut les ajouter manuellement dans /etc/ocsinventory-server/

Par exemple, pour le plugin Officepack :

  1. Aller sur le github du plugin : https://github.com/PluginsOCSInventory-NG/officepack
  2. Récupérer dans le dossier APACHE les deux fichiers (Map.pm et officepack.conf)
  3. Placer le fichier Officepack.conf dans le dossier suivant : /etc/ocsinventory-server/plugins/
  4. Créer un dossier Officepack dans la partie perl : sudo mkdir /etc/ocsinventory-server/perl/Apache/Ocsinventory/Plugins/Officepack/
  5. Placer le fichier Map.pm dans le dossier créé : /etc/ocsinventory-server/perl/Apache/Ocsinventory/Plugins/Officepack/
  6. Changer les droits :
    1. sudo chown www-data:www-data /etc/ocsinventory-server/perl/Apache/Ocsinventory/Plugins/Officepack/Map.pm
    2. sudo chown www-data:www-data /etc/ocsinventory-server/plugins/Officepack.conf
  7. reload apache : sudo systemctl reload apache2
  8. Forcer un inventaire d'une machine pour vérifier
answered Apr 5 by Mimosa (560 points)
selected Apr 6 by Xavier
 
Powered by Question2Answer
...