Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.4 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Server - 2.3.1, Agent - 2.3.0.0 - Message: COM SERVER => fileGet response received <HTTP Status Code #400>

Hi,

I was looking for a solution to my problem but couldn't find any. I'm running OCS Inventory NG Server ver. 2.3.1 and Windows Agent ver. 2.3.0.0. In ocsinventory.log I'm getting the following message:

Starting OCS Inventory NG Agent on Friday, April 07, 2017 22:44:16.
AGENT => Running OCS Inventory NG Agent Version 2.3.0.0
AGENT => Using OCS Inventory NG FrameWork Version 2.3.0.0
AGENT => Loading plug-in(s)
    DLL PLUGIN => Searching for Plug-in DLL(s) in folder <C:\Program Files (x86)\OCS Inventory Agent\plugins>
    DLL PLUGIN => 0 DLL Plug-in(s) successfully loaded on 0 DLL(s) found
AGENT => Using network connection with Communication Server
    COM PROVIDER => Loading Communication Provider <C:\Program Files (x86)\OCS Inventory Agent\ComHTTP.dll>
AGENT => Using Communication Provider <OCS Inventory NG cURL Communication Provider> Version <2.3.0.0>
    AGENT => Sending getLabel request
    COM SERVER => Initializing cURL library for getFile
    COM SERVER => Using cURL without server authentication
    COM SERVER => Disabling cURL proxy support
    COM SERVER => Disabling cURL SSL server validation support
    COM SERVER => Sending fileGet request to URL <http://10.50.1.40/ocsinventory/deploy/label>
    COM SERVER => fileGet response received <HTTP Status Code #400>
    COM SERVER => Cleaning cURL library
    AGENT => Failed to retrieve Label <HTTP Status Code #400>
AGENT => Sending Prolog
    DID_CHECK => Read DeviceID <XXX-1-2017-04-07-22-27-14> and MACs <11:11:11:11:11:1111:11:11:11:11:11> in file <ocsinventory.dat>
    COM SERVER => Initializing cURL library for sendRequest
    COM SERVER => Using cURL without server authentication
    COM SERVER => Disabling cURL proxy support
    COM SERVER => Disabling cURL SSL server validation support
    COM SERVER => Sending HTTP Post request to URL <http://10.50.1.40/ocsinventory>
    COM SERVER => HTTP Post response received <HTTP Status Code #400>
    COM SERVER => Cleaning cURL library
================= TRACE START ===============

================= TRACE STOP ===============
ERROR *** AGENT => Failed to send Prolog <HTTP Status Code #400>
AGENT => Unloading communication provider
AGENT => Unloading plug-in(s)
AGENT => Execution duration: 00:00:00.

I would appreciate any help. Many thanks.

asked Apr 7 in OCS Inventory NG agent for Windows by jasnygwint (160 points)

2 Answers

0 votes
Hello,

I've just found out that Installing WIndows Agent ver. 2.1.1 has solved the issue. There is still a question why the agent 2.3.0.0 doesn't work with the server 2.3.1?
answered Apr 7 by jasnygwint (160 points)
0 votes
It works but only with Windows 7 and above. I think this computer is an XP or W2003 right ?
answered Apr 10 by vincent_n (4,810 points)
 
Powered by Question2Answer
...