Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.6 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Besoin d'aide sur le télédeploiment

Bonjour à tous , j'ai crée un serveur OCS + GLPI sous ubuntu 16.04 , j'arrive a faire la remonter d'inventaire , mais j'aimerais maintenant utiliser le télédéploiement si j'ai bien compris le fonctionnement, il faut activer la connexion SSL et crée un certificat et l'activer, ensuite il faut crée un dossier  " download" dans /var/www/ et lui faut modifier  les droits avec cette commande là  chown -R www-data:www-data /var/www/download/. Mais quand j'essayer d'accéder au dossier à l'aide de mon navigateur ça me met 

ERREUR 403  

Forbidden

You don't have permission to access /download/ on this server.

Serait-il possible de m'éclairé sur les démarche à suivre afin de pouvoir télédéployer des paquets ?

Merci d'avance !

in OCS Inventory NG server for Unix by (550 points)

14 Answers

+1 vote
Salut,

Le dossier par défaut est dans /var/lib/ocsinventory-reports/download/

Surement un souci dans la conf de test fichiers ocsinventory-reports.conf et ou default-ssl.conf, 000-default.conf

Regarde ici : http://www.miloszengel.com/ocs-ng-2-2rc1-server-enable-ssl-for-management-and-deployment/
by (320 points)
Fichier introuvable
0 votes

Salut ,

 Tout d'abord merci beaucoup de m'avoir répondu ! :) 

Alors entre-temps j'ai chercher un peu sur internet et je suis tomber sur ce tuto http://wiki.ocsinventory-ng.org/index.php?title=Howtos:Install_OCS_on_debian/fr , j'ai réussi à accéder à ma page download mais je rencontre un autre soucis , quand je veux activer mon paquet il m'affiche ça : 

Or quand je vais dans mon dossier download j'arrive bien à voir mon fichier : 

Tu sais d'ou ça pourrais venir ?

Merci encore 

by (550 points)
0 votes
Je vois pas bien le screenshot tu peux détailler stp ?
by (320 points)
0 votes

Voici un autre screen  :

 Lors de l'activation du paquet j'ai ce message là , Il me dit que le fichier d'information est introuvable à l'adresse https://192.168.1.16/download , or quand je rentre cette adresse dans mon navigateur on retrouve bien le fichier en question .

Voici deux screen de la configuration du fichier default-ssl.conf :

J'ai modifier la ligne DocumentRoot en y mettant le chemin du dossier par défault ainsi que les deux dernières lignes pour le certificat.

Le texte que j'ai surligner en jaune cela me permet d'autorisé le HTTPS sur Download .

Voici un screen du fichier 000-default.conf , normalement  il n'est pas actif comme j'ai mis le fichier  default-ssl.conf par défault , mais je  me suis dit que sa pourrais venir de là toute même. Par sécurité... 

J'ai modifier la ligne DocumentRoot en y mettant le chemin du dossier par défault.

Et voici un autre screen du fichier ocsinventory-reports.conf

Si tu vois quelque chose d'anormale n'hésite pas me le dire !

En espérant que je t'ai fournie toutes les informations nécessaire afin de résoudre mon soucis ^^ .

Merci encore 

by (550 points)
edited by
0 votes
Les fichiers conf ont l'air corrects.

*Est ce que tu pourrais me donner le contenu du dossier :  1493138891

Comment as tu créé ton package ?
by (320 points)
0 votes

Alors voici le contenue du fichier 1493138891 : 

Et voici les étapes que je fais pour crée un package : 

Tout d'abord je compresse mon fichier en format zip pour les machine clientes sous windows : 

Ensuite je me rend sur mon serveur ocs , je vais dans l'onglet création :

Je choisi de stocker le fichier PDF dans le disque C:\ des machines clientes je clique ensuite sur crée . 

J'arrive à cette page : 

Je choisi 1 seul fragment étant donnée que c'est un petit fichier et je clique sur ok .

Il me dit que le paquet à bien été crée .

Ensuite je me rend dans l'onglet activation , je coche mon paquet et je clique sur la flèche pour l'activer en manuelle , ce qui m'amènent a cette page :  

Et je clique sur OK et ensuite j'ai ce message : 

by (550 points)
+1 vote

Ca c'est un problème de certificat, lorsque tu as créé le certifcat avec la command openssl, est ce que tu as spécifié le CN (doit être ip du serveur ou nom dns) ?

https://192.168.1.16/download t'y accède bien ? 

Il faut aussi voir les log d'apache, est ce que tu vois une erreur du genre (dans error.log) : 

[authz_core:error] [pid 15430] [client 10.0.42.61:8741] AH01630: client denied by server configuration: /var/lib/ocsinventory-reports/download

by (320 points)
0 votes

Alors effectivement ça pourrais venir du certificat car  j'ai ça dans les logs : 

http://www.hostingpics.net/viewer.php?id=405478errorlog.png

Mais je comprend pas j'ai bien mis l'ip du serveur soit 192.168.1.16 . 

Voici un exemple de ce que j'ai mis dans le certificat :
       -----
       Country Name (2 letter code) [AU]:FR
       State or Province Name (full name) [Some-State]:Region
       Locality Name (eg, city) :Ville
       Organization Name (eg, company) [Internet Widgits Pty Ltd]:Entreprise
       Organizational Unit Name (eg, section) :Service
       Common Name (eg, YOUR name) :  192.168.1.16
       Email Address :moi@monFAI.com
Je n'est juste pas mis de mot de passe à la fin cela viendrais de là ?
by (550 points)
+2 votes

Bonjour,

pour le message "Le fichier d'informations est introuvable...", il semblerait que ce soit un bug d'affichage du serveur OCS depuis plusieurs versions.

> Je constate le même problème sur ma configuration mais le paquet est opérationnel, il faut ignorer ce message et répondre OUI à "Etes-vous sûr de vouloir activer ce paquet..."

Ce problème est aussi abordé ici : https://ask.ocsinventory-ng.org/6803/fichier-introuvable

Cordialement, Stéphane

by (26.4k points)
edited by
Ocsiventory.ini
0 votes

Alors effectivement je pense que cela pourrais être un bug d'affichage mais je pense que j'ai quand même un soucis derrière tout ça car quand j'ajoute le paquet sur un machine l'état reste sur NOTIFIED,  est ce que ça prend un certains moment  avant de changer d'état ? voici un image du fichier log : https://www.hostingpics.net/viewer.php?id=159986notified.png

Pourtant j'ai bien récupérer mon certificat sur mon serveur et je l'ai ajouter dans le dossier agent des mes machines clientes.

by (550 points)
edited by
 
Powered by Question2Answer
...