Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.4 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

vbs Plugins do not run Win7 Agent

Hi all,

I have a problem with the new plugins on the agent-side Win7 version 2.3.0.0

Installation of Plugins in OSC-Server 2.3.1 went perfect.
I copied the VBS of the agent folders into the "plugin-folder" of my local agent.

Inventory runs perfect, but non of the plugins is working "networkfolder / teamviewer / winuser / ...."

Rights of vbs in pluginfolder have been set to Full for all users.

Debug of the Log-file says:

Starting OCS Inventory NG Agent on Wednesday, June 21, 2017 17:31:47.
AGENT => Running OCS Inventory NG Agent Version 2.3.0.0
AGENT => Using OCS Inventory NG FrameWork Version 2.3.0.0
AGENT => Loading plug-in(s)
    DLL PLUGIN => Searching for Plug-in DLL(s) in folder <C:\Program Files (x86)\OCS Inventory Agent\plugins>
    DLL PLUGIN => 0 DLL Plug-in(s) successfully loaded on 0 DLL(s) found

What did I do wrong? And why does the agent only look for dll, even if every plugin says ...

Put vbs on agents in order to retrieve their data.

greetz, Sascha

related to an answer for: Plugins doesn't run
asked Jun 21, 2017 in OCS Inventory NG agent for Windows by saschas (180 points)
edited Jun 21, 2017 by saschas

1 Answer

0 votes

Starting OCS Inventory NG Agent on Wednesday, June 28, 2017 17:55:54.
AGENT => Running OCS Inventory NG Agent Version 2.3.0.0
AGENT => Using OCS Inventory NG FrameWork Version 2.3.0.0
AGENT => Loading plug-in(s)
    DLL PLUGIN => Searching for Plug-in DLL(s) in folder <C:\Program Files (x86)\OCS Inventory Agent\plugins>
    DLL PLUGIN => Trying to validate DLL <winupdate.dll> as a Plug-in
    WARNING *** DLL PLUGIN => Failed loading Plug-in DLL <winupdate.dll>, <<<-- The agent only scan DLLs and the pluging are VBS Script [I change the name for test]
    DLL PLUGIN => 0 DLL Plug-in(s) successfully loaded on 0 DLL(s) found
AGENT => Using network connection with Communication Server
    COM PROVIDER => Loading Communication

answered Jun 28, 2017 by anonimo (140 points)
 
Powered by Question2Answer
...