Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.3 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

OCS Inventory migration and upgrade

Hello,

I'm trying to move/upgrade our OCS Inventory to the latest version.

I chose to do a brand new installation for the server (version 2.3.1) on a Linux CentOS 5.11: after installing the required PHP and Perl modules (the VM already had its L.A.M.P. applications), the procedure worked well and the server is now up with the default options.

Then I uploaded the file OCS-NG-Windows-Agent-Setup.exe from the OCS agent bundle (the agent version is 2.1.1, since we still have several Windows XP machines in our network) through the Web Administration Interface: also this upload worked.

Then I setup OCSLogon.exe to distribute the new agent (the PCs in the network already have an older version): I uploaded the file on a Samba share (on a machine other than the OCS Server) and configured its execution in the netlogon script with this line:

\\pdcsamba\setup\OcsLogon.exe /NO_SERVICE /S /DEPLOY=2.1.1.1 /SERVER=http://192.168.10.16/ocsinventory /DEBUG /EDITLOG

The script executes and creates its OcsLogon.log file in the %TEMP% folder, but after execution I cannot see any information about my PC on the OCS Server. This is the log file:

********************************************************
Starting OCS Inventory NG Logon Installer 2.1.0.3 on 30/08/2017 at 9:29:46
Checking if not already running...OK
Parsing command line arguments...OK
Searching OCS Inventory NG Agent installed version...OK (1.0.3.2)
OCS Inventory NG Agent version 1.0.3.2 installed, upgrade to version 2.1.1.1 required.
Download timeout is set to <60000> millisecond.
Download does not use HTTP proxy server.
Downloading file <http://192.168.10.16/ocsinventory/deploy/OCS-NG-Windows-Agent-Setup.exe> without server authentication...OK (C:\Users\CISCOD~1\AppData\Local\Temp\OCS-NG_Agent_Setup.exe)
Starting OCS Inventory NG Agent installer...OK (exit code is OK)
Windows does not automatically start OCS Inventory NG Service, so starting Agent <C:\ocs-ng\Ocsinventory.exe>...OK (exit code is 0)
All done, exiting ;-)

Is really everything OK in this procedure (despite the log file, it seems that the existing agent on the PC isn't upgraded... the log remains the same in repeated executions)? What's missing to complete the inventory?

Thanks in advance for answering...

asked Aug 30 in OCS Inventory NG agent for Windows by combas (220 points)

1 Answer

0 votes
A brief update: despite not working on my PC, I ran anyway OCSLogon.exe with the same configuration on different machines. It seems to work with Windows 7 only: those machines are correctly inventoried.

It doesn't work with Windows XP (the file OcsLogon.log is the same as above, except for the third to last line, where exit code is 2) and with Windows 10 RS2 - a.k.a. "Creators Update", such as my PC.

Hope this helps to find a solution, thanks...
answered Sep 14 by combas (220 points)
 
Powered by Question2Answer
...