Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.3 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Probleme utilisation plugin sous OCS 2.1.2

Bonjour,

Je découvre la possibilité d'utiliser des plugins pour remonter plus d'informations via l'agent installé sur les PCS.

J'ai suivi un tuto qui expliquait comment générer un nouveau package de déploiement en y intégrant un ou plusieurs plugins ( une dizaine de plugins au format zip récupérés sur le site OCS). J'ai déployer ce package via GPO sur une machine de test de mon domaine, installation OK.

Coté interface web d'OCS, quand je clique sur l'iconde gestion des plugins, la page web m'affiche aucun module activé pour votre profil. J'ai donc suivi un autre tuto qui expliquait qu'il fallait copier les fichiers plugins dans un dossier download sur le serveur OCS (debian). J'ai donc créé le dossier download qui n'existait pas dans "\usr\share\oscinventory-reports\ocsreports", et ensuite transféré les fichiers zip (les mêmes que pour la création de mon package) par SCP dans le dossier download.

Pour finir j'ai redémarré le serveur OCS mais le résultat est le même dans la gestion des plugins sur l'interface web, aucun module......

Merci d'avance pour votre aide
asked Sep 3 in OCS Inventory NG server for Unix by katanka (290 points)

4 Answers

+2 votes
 
Best answer
Bonjour @Katanka,

pour la version 2.1.2 du serveur OCS inventory je ne sais pas trop, mais pour la v. 2.3.1 sous Linux, voici la méthode d'installation d'un plugin :

- récupérer le fichier ZIP sur le site OCS et extraire le contenu du dossier "agent" > Vous devez au moins y trouver un .vbs qui sera envoyé sur chaque client Windows, dans le dossier :

C:\Program Files (x86)\OCS Inventory Agent\Plugins\

- Envoyer le .ZIP complet sur le serveur OCS (Debian dans mon cas), dans le dossier déjà existant : /usr/share/ocsinventory-reports/ocsreports/download/

> Si vous avez vous-même créé le dossier "download", il y a certainement un problème (celui-ci est automatiquement créé lors de l'installation du serveur OCS car étant le dossier "officiel" de ses plugins).

- Aller dans l'interface du serveur OCS > section "Plugins" > Gestionnaire de plugins

> Si le ZIP est bien dans le bon dossier ("download" - voir plus haut), vous devez le retrouver dans la liste des plugins pouvant être installés > Choisir votre plugin et cliquer sur "Install"

Vous devez alors retrouver les éléments de votre plugin en dessous des "Données administratives" d'une machine (dans la section "Logiciel" ou "Divers")

> Ne pas oublier de forcer un inventaire sur le PC concerné (ou patienter...) afin de vérifier la remontée d'informations pour cette même machine.

Cordialement, Stéphane
answered Sep 3 by steph78630 (9,980 points)
edited Sep 10 by steph78630
0 votes
Bonjour et merci de m'aider.

Je viens de revoir le tuto de création de package avec ocspackager et effectivement j'ait fait une erreur en fournissant le zip complet du plugin plutot que le seul ficher vbs se trouvant dans le dossier agent du plugin dezippé. Donc si j'ai bien compris je recrée mon ocspackage, pour que le dossier plugins contienne juste les fichiers .vbs sur le pc client.

Côté serveur je confirme n'avoir rencontré aucune erreur ou alarme durant l'installation d'ocs server ( ce n'était pas un upgrade de version). Mais j'ai un doute sur le fait d'avoir créé moi même le dossier download ;)

Par contre côté interface web d'OCS, j'ai juste un icone (3 pièces de puzzle) nommé "Gérer les plugins" et quand je clique dessus une page s'affiche avec le titre plugins encadré et en dessous un message sur fond jaune "aucun module activé pour votre profil". Les fichiers zip, tel quel après les avoir téléchargés, se trouvent bien dans le dossier download.

EDIT : Je viens de restester le déploiement par GPO du nouveau package ( après uninstall et reboot du précédent), seuls 2 scripts vbs aparaissent dans le dossier plugins ( winupdate et winusers) alors que j'en avais spécifié une dizaine lors de la création du package ???
answered Sep 3 by katanka (290 points)
edited Sep 3 by katanka
0 votes
Attention : les plugins en version 2.1 ne sont pas du tout les meme qu'en 2.3 et la methiode d'installation est differente aussi.

Il faut absoluement upgrader OCS dans la derniere version si tu veux pouvoir utiliser les plugins a jour.
answered Sep 4 by kapouik (14,920 points)
0 votes
Merci de cette info kapouik, je vais donc upgrader le serveur OCS et le package en 2.3, de mémoire je crois que la procédure est identique à une installation de base.

EDIT : J'ai upgradé en 2.3 sans rencontrer d'erreur bloquante. Par contre au démarrage de l'interface, mon identification se fait bien mais plus aucun élément de la base actuelle n'apparait !!!! Tous les écrans sont vierges de contenu.
answered Sep 4 by katanka (290 points)
edited Sep 4 by katanka
Il doit te manquer un package pour php. Essais de voir avec php-xml et relance apache.
 
Powered by Question2Answer
...