Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.4 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

PC not inventoried [closed]

Hello,

I just installed a OCS Server 2.3.1 on a Ubuntu Server 17.10.
The Installation worked fine and I am able to log in and work with the webinterface.

I installed the Windows Client on one of our PCs here, the Client log shows success:
-------------------------------------------------------------------------
Starting OCS Inventory NG Agent on Friday, November 03, 2017 08:00:56.
AGENT => Running OCS Inventory NG Agent Version 2.3.1.0
AGENT => Using OCS Inventory NG FrameWork Version 2.3.1.0
AGENT => Loading plug-in(s)
 DLL PLUGIN => Searching for Plug-in DLL(s) in folder <C:\Program Files (x86)\OCS Inventory Agent\plugins>
 DLL PLUGIN => 0 DLL Plug-in(s) successfully loaded on 0 DLL(s) found
AGENT => Using network connection with Communication Server
 COM PROVIDER => Loading Communication Provider <C:\Program Files (x86)\OCS Inventory Agent\ComHTTP.dll>
AGENT => Using Communication Provider <OCS Inventory NG cURL Communication Provider> Version <2.3.1.0>
AGENT => Sending Prolog
 DID_CHECK => Read DeviceID <002-2014-2017-10-30-12-09-40> and MACs <FC:15:B4:01:7D:28E0:9D:31:05:68:EC> in file <ocsinventory.dat>
 COM SERVER => Initializing cURL library for sendRequest
 COM SERVER => Using cURL without server authentication
 COM SERVER => Disabling cURL proxy support
 COM SERVER => Disabling cURL SSL server validation support
 COM SERVER => Sending HTTP Post request to URL <http://ocsinventory-ng/ocsinventory>
 COM SERVER => HTTP Post response received <HTTP Status Code #200>
 COM SERVER => Cleaning cURL library
AGENT => Prolog successfully sent
 AGENT => Prolog Frequency set to 10 hour(s)
 AGENT => Inventory on startup option set to 
AGENT => Unloading communication provider
AGENT => Unloading plug-in(s)
AGENT => Execution duration: 00:00:01.
-----------------------------------------------------------------

Unfortunatelly the Information from the Client ist not shown in the Server.  In the web Interface neither hard- nor softwareinformation is shown.

I hope you can help me.

Regards, Frank

closed with the note: Problem solved - Solution detailed in the post
asked Nov 3, 2017 in OCS Inventory NG server for Unix by FBauf (280 points)
closed Nov 23, 2017 by frankb

2 Answers

0 votes
hello did you configure z-ocsinventory-server.conf with DB infos ?
answered Nov 9, 2017 by vince2010091 (240 points)
0 votes

Thanks for the hint, Vince. I actually edited the z-ocsinventory-Server.conf during the Installation process, but it seems I didn't activate the configuration using the a2enconf command. angry

After enabling the configuration I got another error in my Agent (error code #400). I now found out that my SQL Server was set only to accept Connections from 127.0.0.1. I commented this line in the SQL Server config.

Now I get my Clients updated in my new ocs Server.

Thanks a lot.

answered Nov 23, 2017 by FBauf (280 points)
 
Powered by Question2Answer
...