Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.4 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Remonter d'inventaire / Version Agent et Server [closed]

Bonjour ;

Je viens d'installer OCS Server sur WS 2012R2 que j'ai téléchargé depuis le site officiel V2.1.2

L'agent que j'ai déployé est le 2.3.1 .

J'arrive pas a remonté l'inventaire a mon serveur

Biensûr j'ai lu beaucoup de réponses, mais jusque là ça n'a rien donner , est-ce que la difference de version entre l'agent et le serveur est la cause de mon problème ?

Merci !

Voila le Log client:

==============================================================================
Starting OCS Inventory NG Agent on Monday, December 04, 2017 17:07:37.
AGENT => Running OCS Inventory NG Agent Version 2.3.1.1
AGENT => Using OCS Inventory NG FrameWork Version 2.3.1.1
AGENT => Loading plug-in(s)
AGENT => Using network connection with Communication Server
AGENT => Using Communication Provider <OCS Inventory NG cURL Communication Provider> Version <2.3.1.1>
AGENT => Sending Prolog
ERROR *** AGENT => Failed to send Prolog <HTTP Status Code #404>
AGENT => Unloading communication provider
AGENT => Unloading plug-in(s)
AGENT => Execution duration: 00:00:00.

Log Acces Apach :

10.208.18.15 - - [04/Dec/2017:16:59:33 +0100] "GET /ocsinventory/deploy/label HTTP/1.1" 404 1057 "-" "OCS-NG_WINDOWS_AGENT_v2.3.1.1"
10.208.18.15 - - [04/Dec/2017:16:59:33 +0100] "POST /ocsinventory HTTP/1.1" 404 1057 "-" "OCS-NG_WINDOWS_AGENT_v2.3.1.1"
10.208.18.17 - - [04/Dec/2017:17:00:45 +0100] "GET /ocsinventory/deploy/label HTTP/1.1" 404 1057 "-" "OCS-NG_WINDOWS_AGENT_v2.3.1.1"
10.208.18.17 - - [04/Dec/2017:17:00:45 +0100] "POST /ocsinventory HTTP/1.1" 404 1057 "-" "OCS-NG_WINDOWS_AGENT_v2.3.1.1"
closed with the note: Problème résolu
asked Dec 4 in OCS Inventory NG agent for Windows by Regulus (190 points)
closed Dec 6 by frankb

2 Answers

0 votes
 
Best answer
Bonsoir,

As-tu installé le module mod_perl pour apache? Si oui est-il activé? Ensuite dès que ce module sera actif le serveur 2.1.2 ne saura pas traiter les inventaires des agents 2.3.x. Au maximum le serveur 2.1.2 sait traiter des inventaires 2.1.x. Il te faut donc installer le serveur 2.3.x pour traiter les inventaires des agents 2.3.x et inférieurs. De plus nous encourageons fortement voir expressément l'installation du serveur OCS sur Linux car le code est optimisé pour cet OS et non pour Windows.

Cordialement

Frank
answered Dec 4 by frankb (52,090 points)
selected Dec 5 by Regulus
0 votes
Bonsoir Franck

J'ai finalement fini par refaire une installation sous Debian 9 , tout est OK pour moi (déploiment via GPO ),

Il me reste GLPI à présent ,

Je vous remercie pour votre réponse

Salutations
answered Dec 5 by Regulus (190 points)
 
Powered by Question2Answer
...