Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.4.1 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Import Garantie Dell

Bonjour,

Je ne sais pas trop ou placer ma demande...

Je souhaiterais savoir si il existe un plugin pour remonter les dates de Garantie, et/ou d'achat des machines inventoriées..

Ma version Server OCS: 2.3.1

MonOS: Debian 7 (wheezy) version 5.5.58-0+deb7u1

Apache: 2.2.22 (Debian

PHP: 5.4.4

Merci d'avance

Cordialement,

Epoc

asked in OCS Inventory NG server for Unix by (950 points)

3 Answers

0 votes
Bonjour Epoc,

il n'existe pas de plugin qui permette de remonter les garanties des machines DELL (ou HP).

> J'ai moi-même fait cette recherche il y a quelques mois et j'ai trouvé sur la toile des scripts, malheureusement plus à jour et non fonctionnels.

Le post suivant évoque le même sujet : https://ask.ocsinventory-ng.org/7239/date-dinstallation-du-syst%C3%A8me?show=7257#a7257

N'hésites à me contacter si tu trouves quelque chose afin que je mette la solution à dispo de la communauté par la création d'un plugin.

Cordialement, Stéphane
answered by (22.4k points)
0 votes
Bonjour Steph.

Ok, dans ma situation, j'utilise conjointement GLPI, qui lui a un plugin...

Alors dans les anciennes version de GLPI et de son plugin (Import Fabricant), j'ai eu l'occasion de l'utiliser, et c'est vrai il était fonctionnel, et les service rendus étaient très importants..quand tu as plus de 100 PC et que tu sais "quel age" ils ont...:)

Mais avec les mises à jour GLPI, Plugin et même coté Dell (Clé API), l'info ne remonte pas, et tout faire à la mano, c'est pas top ..:(

Le plugin sur GLPI fonctionne qu'a moitié, il scanne bien touts les PC, mais ne remonte pas les dates de garantie...

Je continue à chercher...si j'ai une info...je poste quelques lignes sur le forum...

Juste pour info, la dernière mise à jour d'OCS la 2.4, est stable ou en test ? elle peut être faite sur Debian 7 PHP5 ou ce n'est pas recommandé..?

Cordialement,

Epoc
answered by (950 points)
0 votes

Cher Epoc,

Effectivement, dans les scripts que j'ai trouvé, le blocage se situe au niveau du site DELL, ils ont ajouté un anti-spam et limité la récupération d'infos en lot (victimes de leur succès ?)

La version 2.4 du serveur OCS est stable et très récente (06/12/2017 - à l'occasion du salon OSS Paris 2017) et elle intègre :

- Plusieurs nouvelles fonctions (cf. détails sur le site)
- Tous les fix validés et émis depuis la 2.3.1

Bref, que du bonheur...

On attendait plus que toi pour nous dire ce que tu en penses :-)

> Coté compatibilité, la Debian 7 n'est pas récente... Pas bien placé sur cette partie, c'est une question à poser à un sys admin de l'équipe (Frankb ou Kapouik par exemple)

Note : Dans ma config (Debian 8 - jessie), 2 dépendances manquantes à installer en amont de la mise à jour du serveur OCS : libmojolicious-perl et libplack-perl


A+, Steph

answered by (22.4k points)
edited by
 
Powered by Question2Answer
...