Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.4 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

[OCS 2.4] Erreur de remonté

Bonjour 

Suite à la mise à jour en 2.4, je n'ai plus de remonté OCS.

Dans l'Error log j'ai bien un message d'erreur qui est le suivant

[Mon Dec 11 09:28:39 2017] [error] [client 10.61.4.8] Can't call method "do" on an undefined value at /usr/local/share/perl/5.14.2/Apache/Ocsinventory/Server/System.pm line 189.\n

J'ai vérifié les fichiers z-ocsinventory-server.conf et dbconfig.inc.php concercant les comptes et mot de passe et redemarré mon serveur Apache


La line 189 concerne la commande suivante $dbh->do("SET sql_mode='NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION'");

asked Dec 11, 2017 in OCS Inventory NG server for Unix by CP (180 points)

4 Answers

0 votes
Bonjour,

Je sais que ca ne va pas faire avancer les choses mais je suis exactement dans la meme situation.
MàJ en 2.4 et plus de remontés d'agents alors que les fichiers z-ocsinventory-server.conf et dbcongi.inc.php sont corrects.
answered Dec 11, 2017 by leygor216 (140 points)
+1 vote
Bonjour,

Avez-vous redémarré apache après la mise à jour? Ce message indique que le mot de passe de connexion à la base de données n'est pas correct dans le fichier z-ocsinventory-server.conf.

Cordialement

Frank
answered Dec 11, 2017 by frankb (53,090 points)
0 votes
Redémarrage Apache et redémarrage serveur fait mais problème identique
answered Dec 11, 2017 by CP (180 points)
+1 vote
I changed the password in z-ocsinventory-server.conf and now it's working again.

Thank you.
answered Dec 12, 2017 by pchamorro (630 points)
 
Powered by Question2Answer
...