Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.4.1 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

After installation my webpage not browse

After installation my webpage not browse both service are running xamp& my sql
asked in OCS Inventory NG server for Windows by (240 points)

5 Answers

0 votes
How do you have install OCS ?

Do you have the apache log ?

What did you mean with 'not browse' ?

Can you describe the exact error you get ?
answered by (17.6k points)
0 votes
I have download from website.after installation complete one shortcut create on desktop while browse its say  HTTP Error 404.0 - Not Found Can we do a remote session  you will also know clear where i am stuck

http://localhost/ocsreports

Dear Sir,

Request you Please take a remote access
*** MODERATOR EDIT : do not put your phone number here
answered by (240 points)
edited by
How do you have install OCS ? Wich package do you have download, how exactly do you have install OCS ?

Do you have the apache log ?

What did you mean with 'not browse' ?

Can you describe the exact error you get ?

Without this answer you will never had any help.
0 votes

How do you have install OCS ? 

 I have gone to website & download ,i have installed ocs software on windows server 2012r2

Wich package do you have download, 

OCSNG-Windows-Server-Setup.exe

how exactly do you have install OCS ?

run that exe file on server & follow the steps

Do you have the apache log ?

yes !

ocsinventory-server: Can't load SOAP::Transport::HTTP* - Web service will be unavailable
ocsinventory-server: Can't load SOAP::Transport::HTTP* - Web service will be unavailable
[Sat Dec 09 12:39:19 2017] [notice] Digest: generating secret for digest authentication ...
[Sat Dec 09 12:39:19 2017] [notice] Digest: done
[Sat Dec 09 12:39:21 2017] [notice] Apache/2.2.21 (Win32) mod_ssl/2.2.21 OpenSSL/1.0.0e PHP/5.3.8 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sat Dec 09 12:39:21 2017] [notice] Server built: Sep 10 2011 11:34:11
[Sat Dec 09 12:39:21 2017] [notice] Parent: Created child process 2084
Apache server shutdown initiated...
::Transport::HTTP* - Web service will be unavailable
ocsinventory-server: Can't load SOAP::Transport::HTTP* - Web service will be unavailable
[Sat Dec 09 12:39:24 2017] [notice] Digest: generating secret for digest authentication ...
[Sat Dec 09 12:39:24 2017] [notice] Digest: done
[Sat Dec 09 12:39:25 2017] [notice] Child 2084: Child process is running
[Sat Dec 09 12:39:25 2017] [notice] Child 2084: Acquired the start mutex.
[Sat Dec 09 12:39:25 2017] [notice] Child 2084: Starting 150 worker threads.
[Sat Dec 09 12:39:25 2017] [notice] Child 2084: Starting thread to listen on port 443.
[Sat Dec 09 12:39:25 2017] [notice] Child 2084: Starting thread to listen on port 443.
[Sat Dec 09 12:39:25 2017] [notice] Child 2084: Starting thread to listen on port 80.
[Sat Dec 09 12:39:25 2017] [notice] Child 2084: Starting thread to listen on port 80.
[Sat Dec 09 12:39:34 2017] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Sat Dec 09 12:39:34 2017] [notice] Child 2084: Exit event signaled. Child process is ending.
[Sat Dec 09 12:39:35 2017] [notice] Child 2084: Released the start mutex
[Sat Dec 09 12:39:36 2017] [notice] Child 2084: All worker threads have exited.
[Sat Dec 09 12:39:36 2017] [notice] Child 2084: Child process is exiting
[Sat Dec 09 12:39:36 2017] [notice] Parent: Child process exited successfully.
[Mon Dec 11 12:03:22 2017] [notice] Digest: generating secret for digest authentication ...
[Mon Dec 11 12:03:22 2017] [notice] Digest: done
[Mon Dec 11 12:03:26 2017] [notice] Apache/2.2.21 (Win32) mod_ssl/2.2.21 OpenSSL/1.0.0e PHP/5.3.8 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Mon Dec 11 12:03:26 2017] [notice] Server built: Sep 10 2011 11:34:11
[Mon Dec 11 12:03:26 2017] [notice] Parent: Created child process 484
ocsinventory-server: Can't load SOAP::Transport::HTTP* - Web service will be unavailable
ocsinventory-server: Can't load SOAP::Transport::HTTP* - Web service will be unavailable
[Mon Dec 11 12:03:31 2017] [notice] Digest: generating secret for digest authentication ...
[Mon Dec 11 12:03:31 2017] [notice] Digest: done
[Mon Dec 11 12:03:35 2017] [notice] Child 484: Child process is running
[Mon Dec 11 12:03:35 2017] [notice] Child 484: Acquired the start mutex.
[Mon Dec 11 12:03:35 2017] [notice] Child 484: Starting 150 worker threads.
[Mon Dec 11 12:03:35 2017] [notice] Child 484: Starting thread to listen on port 443.
[Mon Dec 11 12:03:35 2017] [notice] Child 484: Starting thread to listen on port 443.
[Mon Dec 11 12:03:35 2017] [notice] Child 484: Starting thread to listen on port 81.
[Mon Dec 11 12:03:35 2017] [notice] Child 484: Starting thread to listen on port 81.
[Mon Dec 11 12:26:07 2017] [error] [client 192.0.0.222] Can't call method "do" on an undefined value at C:/xampp/perl/site/lib/Apache/Ocsinventory/Server/System.pm line 177.\n
[Mon Dec 11 12:26:18 2017] [error] [client 192.0.0.222] client denied by server configuration: C:/xampp/htdocs/xampp/, referer: http://192.0.0.222:81/ocsinventory
[Mon Dec 11 12:27:18 2017] [error] [client 192.0.0.222] client denied by server configuration: C:/xampp/htdocs/xampp/
[Mon Dec 11 12:31:18 2017] [error] [client 192.0.0.222] client denied by server configuration: C:/xampp/htdocs/xampp/

What did you mean with 'not browse' ?

http://localhost/ocsreports is not browse 

Can you describe the exact error you get ?

i am not able to view the server web console

answered by (240 points)
I found two different error :

- Can't call method "do" on an undefined value at C:/xampp/perl/site/lib/Apache/Ocsinventory/Server/System.pm line 177.\n

Your mysql credential are not correct. Please modify it in ocsinventory-reports.conf.

- [Mon Dec 11 12:26:18 2017] [error] [client 192.0.0.222] client denied by server configuration: C:/xampp/htdocs/xampp/, referer: http://192.0.0.222:81/ocsinventory

There is a problem in apache configuration. At first, apache listen on port 81 (it should listen on port 80). It look like also than mod_perl is not activ or that the server is not loaded.

Also, OCS Inventory NG is made to run on linux : The windows version is old and just put for testing : never use it in production.
0 votes

Please check the OCS Inventory configuration file on your apache directory (z-ocsinventory-server.conf).

After installing, you need to set up the DB connection params:

  # Master Database settings
  # Replace y by hostname or ip of MySQL server for WRITE
  PerlSetEnv OCS_DB_HOST your_mysql_server
  # Replace y by port where running MySQL server, generally 3306
  PerlSetEnv OCS_DB_PORT your_mysql_port (Default 3306)
  # Name of database
  PerlSetEnv OCS_DB_NAME your_db_name
  PerlSetEnv OCS_DB_LOCAL ocs
  # User allowed to connect to database
  PerlSetEnv OCS_DB_USER your_mysql_user
  # Password for user
  PerlSetVar OCS_DB_PWD your_db_password

answered by (220 points)
0 votes
Dear sir,

I have make changes in config file but still facing issue to open web console

requested please if possible if you take remote access of my pc and help me so i will be very thank full to you..
answered by (240 points)
 
Powered by Question2Answer
...