Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.4 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Linux OCSNG 2.3.1 With Agent 2.3.1.1 Missing Users

Our OCS Inventory NG 2.3.1 With Agent 2.3.1.1 has been missing a lot of computer's usernames. It is very random and nothing seems to fix it. We have tried to uninstall and reinstall it without any changes. I tried to upgrade to OCSNG 2.4 however, I ran into a lot of issues. Is there something I can try to fix this? It has been happening for years. Thanks

- Debian 8.5 64 Bit

asked Dec 18, 2017 in OCS Inventory NG server for Unix by james (680 points)
edited Dec 18, 2017 by james

4 Answers

+1 vote
I have empty usernames in my database too. My guess is the agent rant without any user logged in. Take a look at the time the agent contacted the database too see if there is any correlation.

2017-12-18 21:02:30 SEC18901 Microsoft Windows 10 Pro
answered Dec 20, 2017 by wgalway (530 points)
0 votes
Thank you for the reply. However, it looks like the times it happens is when the user was logged in to the computer. Would it be possible to give the agent more rights to fix this issue?
answered Dec 20, 2017 by james (680 points)
+1 vote
Have you tried deleting the record and performing a forced inventory while a user is currently logged in? Interested in if the issue follows some computers and not others. Just guessing here as I am not a programmer.
answered Dec 20, 2017 by wgalway (530 points)
0 votes

"Have you tried deleting the record and performing a forced inventory while a user is currently logged in? Interested in if the issue follows some computers and not others. Just guessing here as I am not a programmer."

Okay, so I tested your theory and you are correct. I deleted the record from a computer that was missing the username on OCS and reinstalled it while the user was logged out and it came back without a username again. And than I tested it when a user was logged in and it works however, the next time the inventory runs and the user is logged out the username is gone again. So it seems that it only does this when the user is logged out. There has to be a way to add rights or something allowing it to work.

answered Dec 20, 2017 by james (680 points)
 
Powered by Question2Answer
...