Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.5 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

400 Bad Request

When I try to upload a file in the "local import" section, I get an error that says "Error HTTP/1.1 400 Bad Request ​"
I am using OCS version 2.4 running on a Ubuntu 16.04 server.  The issue also exists on the official demo located on this site. 
I have tried using Chrome, Firefox, and Edge, all with the same error.
Does anyone have any idea how to fix this?

Thanks!

asked in OCS Inventory NG server for Unix by (120 points)

3 Answers

0 votes

I have the same problem since 3 months... angry

Fortunately I have an old virtual machine with this option that works ... because I'm really stuck. angry

If someone could finally have the solution ... and reliable documentation to install OCS correctly... thank you in advance ! indecision

answered by (400 points)
0 votes
Hi,

to help you, follow the post (in french) :

https://ask.ocsinventory-ng.org/8857/imports-locaux-impossible

Regards, Stéphane
answered by (22.5k points)
0 votes

edit the file :

/usr/shares/ocsinventory-reports/ocsreports/require/function_files.php

lines 184 instead of :

"Host: $host\n" . "User-Agent: OCS_local_" . GUI_VER . "\r\n" .

try that :

"Host: $host\r\n" . "User-Agent: OCS_local_" . GUI_VER . "\r\n" .

answered by (3.6k points)
 
Powered by Question2Answer
...