Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.4.1 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Mac OS agent can't connect to server [closed]

Installed the Mac OS agent on my computer with no errors.

Agent is not able to connect to the server.

server is ver. 2.4

agent is ver 2.3.1

log is below:

[Thu Feb 15 11:23:50 2018][debug] Ocsinventory unified agent for UNIX, Linux and MacOSX 2.3.1

[Thu Feb 15 11:23:50 2018][debug] Log system initialised (File)

[Thu Feb 15 11:23:50 2018][debug] --scan-homedirs missing. Don't scan user directories

[Thu Feb 15 11:23:50 2018][debug] Accountinfo file: /var/lib/ocsinventory-agent/http:__10.1.16.72_ocsinventory/ocsinv.adm

[Thu Feb 15 11:23:50 2018][debug] OCS Agent initialised

[Thu Feb 15 11:23:50 2018][debug] Turns hooks on for /etc/ocsinventory-agent/modules.conf

[Thu Feb 15 11:23:50 2018][debug] Calling handlers : `start_handler'

[Thu Feb 15 11:23:50 2018][debug] Compress::Zlib is not available! The data will be compressed with

             gzip instead but won't be accepted by server prior 1.02

[Thu Feb 15 11:23:50 2018][debug] Calling handlers : `prolog_writer'

[Thu Feb 15 11:23:50 2018][debug] sending XML

[Thu Feb 15 11:23:50 2018][debug] sending: <?xml version="1.0" encoding="UTF-8"?>

<REQUEST>

  <DEVICEID>Chill-Quanergy-MacBook-Pro-7023-2018-02-14-09-15-58</DEVICEID>

  <QUERY>PROLOG</QUERY>

</REQUEST>

[Thu Feb 15 11:23:50 2018][error] Cannot establish communication : 404 Not Found
closed with the note: Problem solved.
asked in OCS Inventory NG server for Unix by (170 points)
closed by

2 Answers

–1 vote
Hi,

Verify that mod_perl is installed and enabled on your ocs server. Plus install perl Compress::Zlib module on the client.

Kind regards

Frank
answered by (58.3k points)
0 votes
ok i installed compress:zlib.

i restarted apache2 and mod_perl is enabled.

[Fri Feb 16 10:10:25.939670 2018] [mpm_prefork:notice] [pid 5517] AH00163: Apache/2.4.18 (Ubuntu) mod_perl/2.0.9 Perl/v5.22.1 configured -- resuming normal operations

still have the same problem.

The agent is configured to connect to http://[servername]/ocsinventory

but ocsinventory does not exist.
answered by (170 points)
edited by
 
Powered by Question2Answer
...