Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.4.1 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Nothing is displayed on activate list

I have upgraded to 2.4 version and i am trying to make a deploy on all windows machines.
I was able to create a build with
 "    Your package was successfully created in the directory /var/lib/ocsinventory-reports/download/1519719643
       Your package was successfully created in the directory /var/www/html/download/server/1519719775"
messages.
When i go to Activate menu there is no package displayed not automatically or manually created.
I  can see the creation of files in the listed directories , i  also modified the conf file and i am able to access in browser http or https//ocsip/download/
What am ia missing?
asked in Administrative console by (510 points)

6 Answers

0 votes
Hi,

On which distro is installed the server ? Have you errors in apache error log file?

Regards

Frank
answered by (61.3k points)
0 votes
I am using a centos 6 server

There are no errors on apache logs
answered by (510 points)
0 votes
my apache config for download directory is

<Directory /var/lib/ocsinventory-reports/download>
   <IfModule mod_authz_core.c>
     # Apache 2.4
     Require all granted
   </IfModule>
   <IfModule !mod_authz_core.c>
     Order deny,allow
     Allow from all
   </IfModule>
    Options Indexes FollowSymLinks MultiViews

    AllowOverride None
</Directory>
Alias /download /var/lib/ocsinventory-reports/download

i have 775 permissions on download dir

and i have entries in download_available table

Where else should i check?
answered by (510 points)
0 votes
i was able to activate and assign the package to machine. Even if there is nothig displayed on activation list i've selected packages created manually and will appear an input field " Or activate a package manually" where i've put the timestamp of the package created earlier 1519719643. and followed the instructions from there.
answered by (510 points)
0 votes
Hi

I've the same issue.

since migration 2.4 to 2.4.1, no package is displayed on "package activation page", available packages.
Deleted packages works fine.
I still activate manually with the package's number but i can't desactivate.

With debug mode, i see "Processing...". I tried with several browsers. No error on Apache log.

I see an old answer here : http://ask.ocsinventory-ng.org/6801/ocs-inventory-package-activation-page-is-empty but i don't understand the solution.
answered by (250 points)
0 votes

I have same issue and I fixed manually editing the code. Make sure that you have this line on plugins/main_sections/ms_teledeploy/ms_tele_activate.php

$l->g(593) => 'CAST(from_unixtime(FILEID) AS DATETIME)'

You can see the whole bug here:

https://github.com/OCSInventory-NG/OCSInventory-ocsreports/issues/404

answered by (300 points)
 
Powered by Question2Answer
...