Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.5 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Migration 2.1.2 vers 2.4.1

Bonjour,

Je dispose en production d'un serveur OCS linux en version 2.1.2. Souhaitant évoluer vers la version 2.4,  et pour des raisons d'instabilité de la version actuelle, j'ai monté un nouveau serveur OCS 2.4.1. L'installation s'est bien déroulée, un test de récupération de la base existante a été fait et cela semble correct (dump).

Prochaine étape avant le passage en prod, préparer un package d'installation (déployé par GPO), qui prendra en compte les fonctionnalités jusque là non exploitées, à savoir le télédéploiement et l'utilisation des plugins. Ce package sera poussé vers une seule machine afin de valider le bon fonctionnement avec le serveur.

Quelles actions dois je faire pour préparer ce package en tenant compte des fonctionnalités à utiliser ?

Je dois je crois générer un certifcat pour la prise en compte du télédéploiement, le serveur doit-il être accessible uniquement en https ?

Pour les plugins, ils sont à installer côté serveur, côté client ?

Merci de votre aide et de votre compréhension, je reprends une installation en cours et ne possède pas toutes les infos de base

EDIT :

J'ai pu finaliser l'installation des plugins côté serveur, et côté client je dois (si je ne me trompe pas) ajouter Le fichier vbs correspondant à chaque plugin lors de la création du package d'installation de l'agent en utilisant Ocspackager. ( déploiement par GPO).

Pour pouvoir tester le package GPO une seule fois il me reste à aboutir sur la mise en place du SSL sur le serveur OCS et là je bloque encore. J'ai suvi le How-To (Configuration SSL on debian) à la lettre,même si la première étape consistant à créer un fichier ssl doit être interprétée comme ssl.conf. Pas d'erreur rencontrée durant les étapes suivantes mais erreur au restart du service apache :

   Active: failed (Result: exit-code) since mer. 2018-04-25 19:11:06 CEST; 1min 39s ago
  Process: 5166 ExecStop=/etc/init.d/apache2 stop (code=exited, status=0/SUCCESS)
  Process: 5141 ExecReload=/etc/init.d/apache2 reload (code=exited, status=1/FAILURE)
  Process: 5192 ExecStart=/etc/init.d/apache2 start (code=exited, status=1/FAILURE)

avril 25 19:11:06 ocs-srv apache2[5192]: The apache2 configtest failed. ... (warning).
avril 25 19:11:06 ocs-srv apache2[5192]: Output of config test was:
avril 25 19:11:06 ocs-srv apache2[5192]: [Wed Apr 25 19:11:06.623706 2018] [core:error] [pid 5201] (EAI 2)Name or service not known: AH00547: Could not resolve host name nunux.home -- ignoring!
avril 25 19:11:06 ocs-srv apache2[5192]: AH00526: Syntax error on line 20 of /etc/apache2/sites-enabled/ssl.conf:
avril 25 19:11:06 ocs-srv apache2[5192]: Either all Options must start with + or -, or no Option may.
avril 25 19:11:06 ocs-srv apache2[5192]: Action 'configtest' failed.
avril 25 19:11:06 ocs-srv apache2[5192]: The Apache error log may have more information.
avril 25 19:11:06 ocs-srv systemd[1]: apache2.service: control process exited, code=exited status=1
avril 25 19:11:06 ocs-srv systemd[1]: Failed to start LSB: Apache2 web server.
avril 25 19:11:06 ocs-srv systemd[1]: Unit apache2.service entered failed state.

 

J'ai également refait l'installation en suivant ce tuto, sans plus de réussite :Installation alternative de SSL

Je précise que mon serveur étant une VM , je fais des snapshots avant d'entreprendre chacun de ces essais.

asked in OCS Inventory NG server for Unix by (570 points)
edited by

2 Answers

0 votes

Information trouvée dans la doc debian :

Les lignes du type  "Options ExecCGI -MultiViews +SymLinksIfOwnerMatch" , comme celle présente dans le fichier ssl.conf du How-To (ligne 20), doivent :

Toutes être spécifiées avec un - ou un + si une d'entre elles le nécessite ou ne comporter aucun signe - ou +

Dans mon cas (un peu au pif), j'ai ajouté un + devant ExecCGI ce qui donne :

               Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch

J'ai sauvegardé le fichier ssl.conf, redémarré le serveur apache et tout fonctionne.

Je teste le bon fonctionnement, certificat ssl + plugins dans un agent poussé par GPO, sur une machine test

answered by (570 points)
0 votes
Je viens de valider l'accès à l'interface en SSL, l'installation de l'agent via GPO et la remontée de l'inventaire et des infos plugin vers le serveur.

Je n'ai pas encore testé le télédéploiement, par contre lors de la création du package via GPO, j'ai du utiliser le paramètre /FORCE car j'avais un doute sur l'usage du paramètre /DEPLOY. J'avais fixé ce paramètre à 2.1.1.0 et l'agent ne s'est pourtant pas déployé. Avec le /FORCE pas de problème sauf que cela réinstalle l'agent à chaque démarrage, si je peux éviter cette dérive, merci de votre aide.

Dernière étape avant bascule, ma base de prod contient environ 950 ordinateurs et 2000 équipements réseaux, la nouvelle base uniquement 700 ( issu d'un premier dump de la base de prod). Dois-je procéder à une nouvelle sauvegarde/restauration de la base de prod sur la nouvelle base avant de basculer la GPO sur l'OU de production.
answered by (570 points)
 
Powered by Question2Answer
...